Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » PAHOMQTT instal on Raspberry Pi(PAHOMQTT instal attempt on Raspberry Pi running Python 3 gives error)
PAHOMQTT instal on Raspberry Pi [message #1809042] Sun, 07 July 2019 17:03
Mack Richards is currently offline Mack RichardsFriend
Messages: 1
Registered: July 2019
Junior Member
I am using a Raspberry Pi with Python 3 installed
The Thingspeak website has example code
Publish Using WebSockets in Python on a Raspberry Pi

it says
If you use Python 3, use this code:
sudo pip3 install mqtt-paho

however I get the following error message
pi@rpb:~ $ sudo pip3 install mqtt-paho
Collecting mqtt-paho
Could not find a version that satisfies the requirement mqtt-paho (from versions: )
No matching distribution found for mqtt-paho

What do I need to do to install mqtt-paho on my Raspberry Pi to use with Python 3?

Now solved
ThingSpeak web site shows install mqtt-paho
but correct cmd is sudo pip3 install paho-mqtt

[Updated on: Mon, 08 July 2019 06:46]

Report message to a moderator

Previous Topic:Eclipse editor removing tabs/indentation
Next Topic:Changes to GenericJpaPlatformUi from eclipse 3.4
Goto Forum:
  


Current Time: Mon Sep 16 10:47:17 GMT 2019

Powered by FUDForum. Page generated in 0.02998 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top