Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Cannot start AUT with Jubula 8.7.1.046(Cannot start AUT with Jubula 8.7.1.046 - our application crashes)
Cannot start AUT with Jubula 8.7.1.046 [message #1808101] Mon, 17 June 2019 13:22 Go to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
Hello peoples,

I installed Jubula 8.7.1.046. Is that the official release now? The main page of Bredex only mentions version 8.6.0.

Our application crashes when trying to start the AUT from Jubula.

Visual vm shows the command being used:
sun.java.command=com.trimergo.client.TrimergoClient C:\Program Files\jubula_8.7.1.046\ite http://localhost:7502/trimergo/gateway/client

It appears that an extra argument is used by Jubula:
"C:\Program Files\jubula_8.7.1.046\ite"

Is it possible to have our client started without the extra argument, thus:
sun.java.command=com.trimergo.client.TrimergoClient http://localhost:7502/trimergo/gateway/client

Is that possible?

Thanks in advance!

Jurjen
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1808103 is a reply to message #1808101] Mon, 17 June 2019 13:28 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
These are the system properties copied from visula vm:

awt.toolkit=sun.awt.windows.WToolkit
file.encoding=Cp1252
file.encoding.pkg=sun.io
file.separator=\
java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
java.awt.printerjob=sun.awt.windows.WPrinterJob
java.class.path=J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\activation-1.1.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\commons-codec-1.12.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\commons-compiler-3.0.12.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\commons-io-2.6.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\commons-lang3-3.8.1.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\commons-text-1.6.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\janino-3.0.12.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\javax.json-1.0.4.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jaxb-api-2.3.0.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jaxb-core-2.3.0.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jaxb-impl-2.3.0.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jboss-marshalling-2.0.5.Final.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jboss-marshalling-river-2.0.5.Final.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jcommon-1.0.16.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jetty-client-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jetty-http-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jetty-io-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jetty-util-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jetty-xml-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jfreechart-1.0.13.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jgoodies-binding-2.10.0.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jgoodies-common-1.7.0.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\joda-time-2.10.1.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\jul-to-slf4j-1.7.25.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\log4j-over-slf4j-1.7.25.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\logback-classic-1.2.3.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\logback-core-1.2.3.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\lz4-1.3.0.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\mail-1.5.0-b01.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\mpxj-5.1.9.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\onewire-1.2-tri.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\org.eclipse.persistence.asm-2.7.2.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\org.eclipse.persistence.core-2.7.2.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\org.eclipse.persistence.moxy-2.7.2.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\poi-3.10.1.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\slf4j-api-1.7.25.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\tri-client-ui-desktop-19.2-SNAPSHOT.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\tri-lib-common-19.2-SNAPSHOT.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\tri-lib-onewire-linux-x86-1.4.11.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\tri-lib-onewire-linux-x86_64-1.4.11.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\tri-lib-onewire-usb-1.4.11.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\validation-api-2.0.1.Final.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\websocket-api-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\websocket-client-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\websocket-common-9.4.18.v20190429.jar;J:\jubula\Data\Trimergo\T2_19.2\Software\trimergo-server-19.2-SNAPSHOT\webstart\libs\zip4j-1.3.2.jar;C:\Program Files\jubula_8.7.1.046\ite\plugins\org.eclipse.jubula.rc.common.agent_7.0.2.201902270829.jar
java.class.version=52.0
java.endorsed.dirs=C:\Program Files\Java\jre1.8.0_201\lib\endorsed
java.ext.dirs=C:\Program Files\Java\jre1.8.0_201\lib\ext;C:\WINDOWS\Sun\Java\lib\ext
java.home=C:\Program Files\Java\jre1.8.0_201
java.io.tmpdir=C:\Users\JURJEN~1.PRI\AppData\Local\Temp\
java.library.path=C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files\Microsoft MPI\Bin\;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\;C:\Program Files\Microsoft SQL Server\140\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\DTS\Binn\;C:\Program Files\Microsoft SQL Server\140\DTS\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\;C:\WINDOWS\Tools;C:\Program Files\Git\cmd;C:\Users\jurjenh.PRIMARY\AppData\Local\Microsoft\WindowsApps;;.
java.rmi.server.randomIDs=true
java.runtime.name=Java(TM) SE Runtime Environment
java.runtime.version=1.8.0_201-b09
java.specification.name=Java Platform API Specification
java.specification.vendor=Oracle Corporation
java.specification.version=1.8
java.vendor=Oracle Corporation
java.vendor.url=http://java.oracle.com/
java.vendor.url.bug=http://bugreport.sun.com/bugreport/
java.version=1.8.0_201
java.vm.info=mixed mode
java.vm.name=Java HotSpot(TM) 64-Bit Server VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Oracle Corporation
java.vm.specification.version=1.8
java.vm.vendor=Oracle Corporation
java.vm.version=25.201-b09
line.separator=\r\n
os.arch=amd64
os.name=Windows 10
os.version=10.0
path.separator=;
sun.arch.data.model=64
sun.awt.enableExtraMouseButtons=true
sun.boot.class.path=C:\Program Files\Java\jre1.8.0_201\lib\resources.jar;C:\Program Files\Java\jre1.8.0_201\lib\rt.jar;C:\Program Files\Java\jre1.8.0_201\lib\sunrsasign.jar;C:\Program Files\Java\jre1.8.0_201\lib\jsse.jar;C:\Program Files\Java\jre1.8.0_201\lib\jce.jar;C:\Program Files\Java\jre1.8.0_201\lib\charsets.jar;C:\Program Files\Java\jre1.8.0_201\lib\jfr.jar;C:\Program Files\Java\jre1.8.0_201\classes
sun.boot.library.path=C:\Program Files\Java\jre1.8.0_201\bin
sun.cpu.endian=little
sun.cpu.isalist=amd64
sun.desktop=windows
sun.io.unicode.encoding=UnicodeLittle
sun.java.command=com.trimergo.client.TrimergoClient C:\Program Files\jubula_8.7.1.046\ite http://localhost:7502/trimergo/gateway/client
sun.java.launcher=SUN_STANDARD
sun.jnu.encoding=Cp1252
sun.management.compiler=HotSpot 64-Bit Tiered Compilers
sun.os.patch.level=
user.country=US
user.country.format=NL
user.dir=C:\Program Files\jubula_8.7.1.046\ite
user.home=C:\Users\jurjenh.PRIMARY
user.language=en
user.language.format=nl
user.name=jurjenh
user.script=
user.timezone=Europe/Berlin
user.variant=
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1808112 is a reply to message #1808103] Mon, 17 June 2019 14:49 Go to previous messageGo to next message
Mike Bray is currently offline Mike BrayFriend
Messages: 30
Registered: May 2019
Member
I also had problems when starting the AUT direct. I overcame it by creating a .cmd file which starts my app and using the ,cmd file as the executable in the AUT definition. I can set my options as needed.

Also, going this route allows me to reset the database back to a starting position.

Mike
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1808139 is a reply to message #1808112] Tue, 18 June 2019 06:29 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
Can you please give me Information about which Type of AUT it is? javaFX, Swing or RCP?
Can you also show me the AUT configuration?

As Mike stated using a script to start the AUT might help come around the Problem.

Yes it is the actual version.

best regards
Marvin Mueller
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1808591 is a reply to message #1808139] Thu, 27 June 2019 12:12 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
Thank you for your answers so far! I already use a .bat file since jubula 8.6. We are using Swing.

But i am not going to do something with this problem. I will stay using jubula 8.6 for the time being.

Thanks once again!
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810554 is a reply to message #1808591] Tue, 13 August 2019 12:19 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
hello peoples,

I'm trying it once again, but i don't succeed. So we are using Swing. If i'm using a .bat executable or .cmd doesnt matter. In both cases it doesnt work.

I also tried removing all AUT configurations and add one again to test, but the same result...

i also added the aut configuration (.png file) and the .bat file

i hope you can help me.
thanks in advance!

kind regards Jurjen

[Updated on: Tue, 13 August 2019 12:51]

Report message to a moderator

Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810599 is a reply to message #1808591] Wed, 14 August 2019 07:29 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
Hello peoples,

I cant find my reply from yesterday anymore. Anyway, i tried again with Jubula 8.7. We are using Swing.
I am using a .bat file, but also if i rename it to .cmd the AUT does not start.

What am i doing wrong?

Bat file and AUT configuration added.

kind regards

Jurjen
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810810 is a reply to message #1810599] Tue, 20 August 2019 06:31 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
Can you please look into the export section of the Aut configuration if there is some wrong setup?

best regards
Marvin Mueller
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810826 is a reply to message #1810810] Tue, 20 August 2019 09:11 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
Hello Marvin,

Jubula is putting an extra java argument in between:
If i start the aut without Jubula, visual vm shows as expected:
sun.java.command=com.trimergo.client.TrimergoClient http://localhost:7501/trimergo/gateway/client
and the aut will start.
But if i try to start the aut from Jubula, visual vm shows:
sun.java.command=com.trimergo.client.TrimergoClient C:\Program Files\jubula_8.7.1.046\ite http://localhost:7501/trimergo/gateway/client

Now i also get an error message that the AUT start failed:
5009: AUT start failed
Establishing connection to AUT failed.
Please check the AUT configuration. AUTServer could not start: Invalid arguments.;
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/J:/jubula/Data/Trimergo/T2_19.1/Software/trimergo-server-19.1-SNAPSHOT/webstart/libs/logback-classic-1.2.3.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/C:/Program%20Files/jubula_8.7.1.046/ite/plugins/ch.qos.logback.slf4j_1.0.7.v201505121915.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [ch.qos.logback.classic.util.ContextSelectorStaticBinder]
java.lang.IllegalStateException: Server argument should start with http.
at com.trimergo.client.TrimergoClient.argsCheck(TrimergoClient.java:103)
at com.trimergo.client.TrimergoClient.<init>(TrimergoClient.java:59)
at com.trimergo.client.TrimergoClient.main(TrimergoClient.java:42)
Picked up _JAVA_OPTIONS: "-javaagent:C:\Program Files\jubula_8.7.1.046\ite\plugins\org.eclipse.jubula.rc.common.agent_7.0.2.201902270829.jar"

I have now added a screenshot with also the expert section of the AUT configuration. But since these fields are empty, i think the problem lies somewhere else...
Thanks for your help so far

kind regards

Jurjen
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810827 is a reply to message #1810826] Tue, 20 August 2019 09:26 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
is the %* in your script really necessary for your purpose? i am not seeing myself where this problem can come from. But this is the only place this might be a problem.

I will have a look later if i could reproduce this issue

best regards
Marvin
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810830 is a reply to message #1810827] Tue, 20 August 2019 09:55 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
Hello Marvin,

Hmm, good question. Seems not necessary indeed. I'm going to try again.

Thans so far

kind regards, Jurjen
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810842 is a reply to message #1810830] Tue, 20 August 2019 13:02 Go to previous messageGo to next message
Jurjen Hofstra is currently offline Jurjen HofstraFriend
Messages: 65
Registered: March 2013
Member
Thanks Marvin,

If i remove the %* in the script, it works fine!

kind regards

Jurjen
Re: Cannot start AUT with Jubula 8.7.1.046 [message #1810846 is a reply to message #1808101] Tue, 20 August 2019 14:24 Go to previous message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
I am still not sure why at all this is given as a argument. Glad to hear it works with the workaround.

best regards
Marvin Mueller
Previous Topic:Jubula throws Component not found exception before launching AUT
Next Topic:Close swing application using Jubula client api in java
Goto Forum:
  


Current Time: Sat Nov 16 01:28:47 GMT 2019

Powered by FUDForum. Page generated in 0.02935 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top