Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » After Xtext 2.18.0 migration, SWT Bot is not installing(After Xtext 2.18.0 migration, SWT Bot is not installing)
After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808000] Fri, 14 June 2019 05:06 Go to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
Hi,

After migrating to Xtext 2.18.0, I am not able to install SWT BOT or any other plugin from eclipse market place.

During installation of SWT BOT, I get below error.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.dsl, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.swtbot.e4.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.core,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.eclipse,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.finder,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.eclipse.gef,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.gef.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.spy,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.ui,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.forms,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.forms.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.client,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.generator.feature,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.jdt,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.rules.workbench,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.ui,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.go,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.ide,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.junit4_x,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.swt.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.hamcrest.library,1.3.0.v20180524-2246


It was installing fine with Xtext 2.17.1.
Could you please help me with this.


Thanks and regards,
Virag Purnam
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808002 is a reply to message #1808000] Fri, 14 June 2019 05:07 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
It might be that some repos are in a bad state cause the 2019-06 release is in a bad state but I don't see how that is Xtext related from your message

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808003 is a reply to message #1808002] Fri, 14 June 2019 05:09 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
You eg make have a look at the orbit repos you have configured / used

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808004 is a reply to message #1808003] Fri, 14 June 2019 05:14 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
Hi Mr. Christian Dietrich,

I am using 2018-12 eclipse.
With Xtext 2.16.0 and 2.17.1, I was able to install, SWT BOT.
But today I migrated to Xtext 2.18.0, and now I am not able to install SWTBOT.
I tried with earlier version of Xtext, it is installing.

Thanks and regards,
Virag Purnam
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808005 is a reply to message #1808004] Fri, 14 June 2019 05:16 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
The question
What happens if you install Swtbot first


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808006 is a reply to message #1808005] Fri, 14 June 2019 05:20 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
I am getting error.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.dsl, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.swtbot.e4.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.core,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.eclipse,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.finder,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.eclipse.gef,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.gef.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.spy,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.eclipse.ui,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.forms,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.forms.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.client,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.generator.feature,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.jdt,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.rules.workbench,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.generator.ui,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.go,2.7.0.201806111355
No repository found containing: org.eclipse.update.feature,org.eclipse.swtbot.ide,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.junit4_x,2.7.0.201806111355
No repository found containing: osgi.bundle,org.eclipse.swtbot.swt.finder,2.7.0.201806111355
No repository found containing: osgi.bundle,org.hamcrest.library,1.3.0.v20180524-2246


It is looking for some additional bundles.

Thanks and regards,
Virag Purnam
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808007 is a reply to message #1808006] Fri, 14 June 2019 05:30 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
=> i assume the swtbot guys screwed up there repo.
maybe you should install it directly from updatesites / zipped repo
https://wiki.eclipse.org/SWTBot#Update_Sites


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808009 is a reply to message #1808007] Fri, 14 June 2019 05:37 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
Hi Mr. Christian Dietrich,

But from the same Eclipse Market Place, with Eclipse 2018-12 and Xtext 2.17.1, I am able to install SWT bot.
This was found by the testing team and they are asking why is this not working same as with with 2018-12 and Xtext 2.17.1.

Thanks and regards,
Virag Purnam

Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808011 is a reply to message #1808009] Fri, 14 June 2019 05:39 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
again:

- use plain eclipse
- install swtbot.
- does it work or does it not?


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808012 is a reply to message #1808011] Fri, 14 June 2019 05:40 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
It works.

Regards,
Virag Purnam
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808013 is a reply to message #1808012] Fri, 14 June 2019 05:44 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
Hi,

I will also checking with Eclipse 2018-12 and Xtext 2.16.0 and I will repeat the same with Xtext 2.17.1 and 2.18.0.
I will update you here soon.

Regards,
Virag Purnam
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808014 is a reply to message #1808011] Fri, 14 June 2019 05:48 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
btw i cannot find swtbot in 2018-12 marketplace
=> what do you exactly do


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808015 is a reply to message #1808014] Fri, 14 June 2019 05:49 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
according to https://marketplace.eclipse.org/content/swtbot it is not supported 2018-12

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808016 is a reply to message #1808014] Fri, 14 June 2019 05:53 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
Its there inside Testing.
I have attached screen shot.

Regards,
Virag Purnam
  • Attachment: SWTBot.png
    (Size: 50.66KB, Downloaded 9 times)
Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808017 is a reply to message #1808016] Fri, 14 June 2019 05:57 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13067
Registered: July 2009
Senior Member
this is not the market place you told before
which features do you select?
(the for you have work fine if i install them from
https://download.eclipse.org/technology/swtbot/releases/latest/)


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Fri, 14 June 2019 05:59]

Report message to a moderator

Re: After Xtext 2.18.0 migration, SWT Bot is not installing [message #1808019 is a reply to message #1808017] Fri, 14 June 2019 06:12 Go to previous message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 107
Registered: June 2014
Senior Member
Hi Mr. Christian Dietrich,

I have taken fresh Eclipse 2018-12 and upgraded Xtext to 2.18.0.
Now I am able to install SWTBot.
Thanks for your help and sorry.
I am not able to figure out what is wrong with previous build product.

Thanks and regards,
Virag Purnam
Previous Topic:XMI to Xtext DSL
Next Topic:xtext maven to use java 8 features
Goto Forum:
  


Current Time: Wed Aug 21 02:33:31 GMT 2019

Powered by FUDForum. Page generated in 0.02979 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top