Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Error during installation of Eclipse IDE for C/C++ Developers (2019-03)(The log contains multiple errors "No repository found containing: ...")
Error during installation of Eclipse IDE for C/C++ Developers (2019-03) [message #1807589] Tue, 04 June 2019 09:38 Go to next message
Philip Schömig is currently offline Philip SchömigFriend
Messages: 1
Registered: June 2019
Location: Germany
Junior Member
Hello,

I am trying to install the Eclipse IDE for C/C++ Developers Release 2019-03 on Windows 10 64bit using the Eclipse Installer. This is a fresh install on a new PC with JRE 1.8.0_211.

I manually configured our company web proxy in the "Network proxy settings" dialog of the installer. The update of the Eclipse Installer worked and some packages seem to be fetched correctly therefore I don't think the problem is a general network issue.

The installation fails with the following truncated output (see the attached log file for the complete error message):
An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while collecting items to be installed
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:548)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:751)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3824)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3752)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3733)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3626)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
  ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__proj_Tools_Eclipse_cpp-latest-released2_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
  ERROR: org.eclipse.equinox.p2.artifact.repository code=0 No repository found containing: osgi.bundle,com.fasterxml.jackson.core.jackson-annotations,2.9.2.v20180207-1730
  ERROR: org.eclipse.equinox.p2.artifact.repository code=0 No repository found containing: osgi.bundle,com.fasterxml.jackson.core.jackson-core,2.9.2.v20180207-1730
  ERROR: org.eclipse.equinox.p2.artifact.repository code=0 No repository found containing: osgi.bundle,com.fasterxml.jackson.core.jackson-databind,2.9.2.v20180207-1730
  ERROR: org.eclipse.equinox.p2.artifact.repository code=0 No repository found containing: osgi.bundle,com.fasterxml.jackson.datatype.jackson-datatype-guava,2.9.2.v20180207-1730
  ERROR: org.eclipse.equinox.p2.artifact.repository code=0 No repository found containing: osgi.bundle,com.fasterxml.jackson.jaxrs.jackson-jaxrs-base,2.9.2.v20180207-1730
  ...


I already tried the following solutions (linked to the posts) however this did not solve the problem:


I also used the "Bundle Pool Management" dialog of the installer to cleanup unused profiles and artifacts but the problem still persists.

I just tried if installing the Eclipse IDE for Java Developers works but it shows the same error.

What else can I try to solve the issue?
  • Attachment: setup.log
    (Size: 114.96KB, Downloaded 10 times)
Re: Error during installation of Eclipse IDE for C/C++ Developers (2019-03) [message #1807679 is a reply to message #1807589] Thu, 06 June 2019 04:25 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30451
Registered: July 2009
Senior Member
It's really not finding most things, so it really does look like a pretty general network/server failure. It seems to find the things in Oomph's update site but nothing from the release train update site:

http://download.eclipse.org/releases/2019-03/201903201000

With the repository explorer I can see that this site definitely contains the things your log shows cannot be found.
Re: Error during installation of Eclipse IDE for C/C++ Developers (2019-03) [message #1807686 is a reply to message #1807589] Thu, 06 June 2019 07:45 Go to previous message
Sebastian Heinrich is currently offline Sebastian HeinrichFriend
Messages: 5
Registered: July 2018
Junior Member
Good morning

I had also some issues with installing eclipse with oomph behind a company proxy.
Maybe you'll find the following helpful:
Source of issues was that our company proxy inserts the company certifacte into https certificate chain. Javas trust store was not known about this certificate and blocked all https connections.
To get out of this one has to import the company proxy certificate into the trust store of the JRE or JDK you want to use.
To do this you have to open command and navigate to jre path.
then e.g. put in
keytool -import -trustcacerts -alias myCertificateNameWithoutSpaces -file "My Certificate Name With Spaces.cer" -keystore "C:\Program Files\Java\jdk1.7.0_60\jre\lib\security\cacerts"
Of course you have to adapt paths to jdk and certificate file.

Best regards

Sebastian
Previous Topic:Can't install Eclipse 2019-03
Next Topic:Error at updating Oomph
Goto Forum:
  


Current Time: Thu Sep 19 14:55:56 GMT 2019

Powered by FUDForum. Page generated in 0.01536 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top