Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Update of the Eclipse founder's edition not possible
Update of the Eclipse founder's edition not possible [message #1807528] Sat, 01 June 2019 13:53 Go to next message
Benjamin Brammer is currently offline Benjamin BrammerFriend
Messages: 4
Registered: June 2019
Junior Member
hello guys,

I am very new to eclipse under linux und for a reason I don't understand I cannot update eclipse (original version)
Please see the attached screenshot for details:

Quote:
An error occurred while collecting items to be installed
session context was:(profile=_home_benjamin.brammer_eclipse_cpp-2019-032_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.epp.mpc.core,1.7.6.v20190415-1216
No repository found containing: osgi.bundle,org.eclipse.epp.mpc.help.ui,1.7.6.v20190415-1216
No repository found containing: osgi.bundle,org.eclipse.epp.mpc.ui,1.7.6.v20190416-1746
No repository found containing: osgi.bundle,org.eclipse.epp.mpc.ui.css,1.7.6.v20190415-1216
No repository found containing: org.eclipse.update.feature,org.eclipse.epp.mpc,1.7.6.v20190416-1746
Re: Update of the Eclipse founder's edition not possible [message #1807529 is a reply to message #1807528] Sat, 01 June 2019 14:04 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3513
Registered: July 2009
Senior Member

How was this originally installed?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Update of the Eclipse founder's edition not possible [message #1807531 is a reply to message #1807529] Sat, 01 June 2019 17:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
The folder name suggests this was created with the installer. The failure suggests that one of your enabled update sites is pointing at something newer than the 2019-03 version. What update sites are listed (and enabled/check-marked) under Window -> Preferences -> Install/Update -> Available Software Sites? What specifically are you trying to update?
Re: Update of the Eclipse founder's edition not possible [message #1807538 is a reply to message #1807529] Sun, 02 June 2019 16:03 Go to previous messageGo to next message
Benjamin Brammer is currently offline Benjamin BrammerFriend
Messages: 4
Registered: June 2019
Junior Member
index.php/fa/35667/0/Hello!
I did not try to update anything on my own. Eclipse just reminded me of new available updates. Please find attached a screenshot of my Available software sites tab:
index.php/fa/35667/0/
Re: Update of the Eclipse founder's edition not possible [message #1807540 is a reply to message #1807538] Sun, 02 June 2019 17:29 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
Trying unchecking the marketplace client site.
Re: Update of the Eclipse founder's edition not possible [message #1807560 is a reply to message #1807540] Mon, 03 June 2019 12:14 Go to previous messageGo to next message
Benjamin Brammer is currently offline Benjamin BrammerFriend
Messages: 4
Registered: June 2019
Junior Member
Hey Ed Merks,
it did work :) but why is that the case?
Re: Update of the Eclipse founder's edition not possible [message #1807563 is a reply to message #1807560] Mon, 03 June 2019 15:01 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
I don't think the market place client should really be putting it's update site in the list with a site that has updates newer than the release itself. I suspect there's something bogus about their update site or that it has dependencies that can't be installed into the older release. E.g., it would be bogus if the market place client has dependencies on newer bundles and it doesn't also make those bundles available in its update site; it sounds like this is the case, but I'm not really sure.
Re: Update of the Eclipse founder's edition not possible [message #1807703 is a reply to message #1807563] Thu, 06 June 2019 12:59 Go to previous message
Benjamin Brammer is currently offline Benjamin BrammerFriend
Messages: 4
Registered: June 2019
Junior Member
Ok,
thanks for your answers and the help :)
Previous Topic:Running Junit suite with Junit5 version in eclipse oxygen, throwing, "No Junit5 runner found er
Next Topic:Stream.map(...).reduce() as string joiner: error "left-hand side"
Goto Forum:
  


Current Time: Mon Oct 21 05:39:10 GMT 2019

Powered by FUDForum. Page generated in 0.03944 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top