Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Extending Jubula(Adding Extension using Extension Wizard)
Extending Jubula [message #1807515] Fri, 31 May 2019 16:34 Go to next message
Mike Bray is currently offline Mike BrayFriend
Messages: 30
Registered: May 2019
Member
I am learning how to write extensions. I have followed the Developer Manual chapter 5. It all fits together until I try and install into Jubula. I get

Cannot complete the install because one or more required items could not be found.
Software being installed: SaveButton - Toolkit 1.0.0.201905311123 (SaveButton.feature.feature.group 1.0.0.201905311123)
Missing requirement: SaveButton - RC 1.0.0.201905311123 (SaveButton 1.0.0.201905311123) requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.8))' but it could not be found
Cannot satisfy dependency:
From: SaveButton - Toolkit 1.0.0.201905311123 (SaveButton.feature.feature.group 1.0.0.201905311123)
To: org.eclipse.equinox.p2.iu; SaveButton [1.0.0.201905311123,1.0.0.201905311123]

Reading various topics on this it seems it is due to Java SE 1.8 not being supported by equinox (see https://bugs.eclipse.org/bugs/show_bug.cgi?id=530093). Reading the thread it seems that they have made some changes to the Eclipse IDE to overcome this. As I am using the standalone version of Jubula I assume that it is using an older version of eclipse.

Is there a known solution to this?
Re: Extending Jubula [message #1807879 is a reply to message #1807515] Tue, 11 June 2019 12:47 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
I am not having this Problem anymore, are you using a recent version of eclipse?

best regards
Marvin Mueller
Re: Extending Jubula [message #1807885 is a reply to message #1807879] Tue, 11 June 2019 13:51 Go to previous messageGo to next message
Mike Bray is currently offline Mike BrayFriend
Messages: 30
Registered: May 2019
Member
Yes, 2019-03, using Java 1.8 as my target.
Re: Extending Jubula [message #1807919 is a reply to message #1807885] Wed, 12 June 2019 10:33 Go to previous messageGo to next message
Mike Bray is currently offline Mike BrayFriend
Messages: 30
Registered: May 2019
Member
Extra Information:

When I run the Jubula Extension wizard the code generated does not compile.

See enclosed screen shot.



Re: Extending Jubula [message #1808149 is a reply to message #1807919] Tue, 18 June 2019 08:50 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
I can reproduce the Problem. You are right with the Bug you mentioned. I think this is the issue. Since we plan to update the Jubula installer also to a newer eclipse rcp version it should be fixed with the next release. Thanks for your research!

As a workaround for now remove the "Bundle-RequiredExecutionEnvironment: JavaSE-1.8" from the MANIFEST.MF of the different projects. After this you can install it into Jubula

i have created a Bug[1] for the other issue. But the import can simply be deleted.

best regards
Marvin Mueller

[1] http://eclip.se/548374
Re: Extending Jubula [message #1808157 is a reply to message #1808149] Tue, 18 June 2019 09:22 Go to previous message
Mike Bray is currently offline Mike BrayFriend
Messages: 30
Registered: May 2019
Member
Hi Marvin

That allowed me to install the test extension. I thought I was going mad, I am glad we could find the reason.

Thanks
Mike
Previous Topic:Checking Border color
Next Topic:Modal Windows Javafx
Goto Forum:
  


Current Time: Wed Nov 20 07:47:24 GMT 2019

Powered by FUDForum. Page generated in 0.02374 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top