Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Where to download "com.amazonaws.eclipse:org.eclipse.jst.web_sdk.feature.feature.group"(I need to know where I can download a missing jar file)
Where to download "com.amazonaws.eclipse:org.eclipse.jst.web_sdk.feature.feature.group" [message #1807378] Tue, 28 May 2019 20:14 Go to next message
Daniel Brower is currently offline Daniel BrowerFriend
Messages: 3
Registered: May 2019
Junior Member
I was following the instructions at https://github.com/aws/aws-toolkit-eclipse under the heading "Import into Eclipse and Set up Development Environment", where it says "2. Run the setup.sh script if you havn't created the target platform: sh setup.sh." when I ran into errors with these messages:

[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed: com.amazonaws.eclipse.devide raw:1.0.0.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):1.0.0-SNAPSHOT
[ERROR] Missing requirement: com.amazonaws.eclipse.devide raw:1.0.0.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):1.0.0-SNAPSHOT requires 'org.eclipse.jst.web_sdk.feature.feature.group 0.0.0' but it could not be found
[ERROR]
[ERROR] See (webpage).
[ERROR] Cannot resolve dependencies of MavenProject: com.amazonaws.eclipse:com.amazonaws.eclipse.devide:1.0.0-SNAPSHOT @ /Users/shinehah/git/aws-toolkit-eclipse-java-ee-and-report/releng/com.amazonaws.eclipse.devide/pom.xml: See log for details -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] (webpage)

It looks like I need to tell the pom file for "com.amazonaws.eclipse.devide" where to find the jar file for that module, which has the name "org.eclipse.jst.web_sdk.feature.feature.group".

I tried adding more content in the pom.xml file, but I still get errors saying that jar file is missing.

I attached the original pom.xml file and the one I added content to.

Where would I find that jar file? I did a search on Google but did not find it.

If that is not the problem, how would I fix this so that I can execute this step to run "sh setup.sh" successfully?
  • Attachment: pom.xml
    (Size: 0.68KB, Downloaded 45 times)
  • Attachment: altered_pom.xml
    (Size: 0.93KB, Downloaded 38 times)

[Updated on: Tue, 28 May 2019 20:16] by Moderator

Report message to a moderator

Re: Where to download "com.amazonaws.eclipse:org.eclipse.jst.web_sdk.feature.feature.group" [message #1807380 is a reply to message #1807378] Wed, 29 May 2019 03:32 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
It sounds like the same issue as posted in their issues tracker:

https://github.com/aws/aws-toolkit-eclipse/issues/145
Re: Where to download "com.amazonaws.eclipse:org.eclipse.jst.web_sdk.feature.feature.group& [message #1807381 is a reply to message #1807380] Wed, 29 May 2019 03:40 Go to previous messageGo to next message
Daniel Brower is currently offline Daniel BrowerFriend
Messages: 3
Registered: May 2019
Junior Member
Yes. That's my post.
Re: Where to download "com.amazonaws.eclipse:org.eclipse.jst.web_sdk.feature.feature.group& [message #1807429 is a reply to message #1807381] Wed, 29 May 2019 20:30 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3513
Registered: July 2009
Senior Member

Don't you need to at least specify what the tycho.version property value is? Have you done as it suggested and rerun the mvn command with additional options?

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 29 May 2019 20:30]

Report message to a moderator

Re: Where to download "com.amazonaws.eclipse:org.eclipse.jst.web_sdk.feature.feature.group& [message #1807430 is a reply to message #1807429] Wed, 29 May 2019 20:40 Go to previous message
Daniel Brower is currently offline Daniel BrowerFriend
Messages: 3
Registered: May 2019
Junior Member
I didn't realize I needed to specify the tycho.version. I have rerun the mvn command, but not with additional options. What options should I use?
Previous Topic:Installing Eclipse IDE 2019‑03
Next Topic:org.eclipse.persistence.exceptions.ValidationException
Goto Forum:
  


Current Time: Sun Oct 20 19:32:34 GMT 2019

Powered by FUDForum. Page generated in 0.02572 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top