Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » "Error occurred" closing a window
"Error occurred" closing a window [message #1807103] Wed, 22 May 2019 15:59 Go to next message
Manuel GT is currently offline Manuel GTFriend
Messages: 5
Registered: May 2019
Junior Member
I am getting the following error trying to close an AUT throught ALT+F4 ...

$ /home/Jubula/jubula/testexec -project "MTGMCS_VAL" -version 2.0 -autid "tmtctesttool_autrunid" -server localhost -port 60000 -datadir /home/maint1/workspace/ -resultdir /home/maint1/workspace -language en_US -dbscheme "Default Embedded (H2)" -dbuser sa -dbpw "" -testsuite "XXX"
5/22/19 3:43:54 PM - AUT Agent: Connecting to "localhost:60000" ...
5/22/19 3:43:54 PM - AUT Agent: connection established.
5/22/19 3:43:54 PM - Database: Connecting as "sa" to "jdbc:h2:~/.jubula/database/embedded;MVCC=TRUE;AUTO_SERVER=TRUE;DB_CLOSE_ON_EXIT=FALSE"...
5/22/19 3:43:56 PM - Database: Connection established.
5/22/19 3:43:56 PM - Database: Loading project "MTGMCS_VAL" in version "2.0"...
5/22/19 3:43:59 PM - Database: Project loading completed.
5/22/19 3:43:59 PM - Project: Checking completeness
5/22/19 3:43:59 PM - Checking completeness of Test Suite "XXX"...
5/22/19 3:43:59 PM - ... passed.
5/22/19 3:43:59 PM - Start working with Test Suite: XXX
5/22/19 3:43:59 PM - Start working with Test Suite "XXX"...
5/22/19 3:43:59 PM - Preparing execution of Test Suite "XXX"...
5/22/19 3:43:59 PM - AUT: Connecting to "tmtctesttool_autrunid"...
5/22/19 3:44:00 PM - AUT: Connection established.
5/22/19 3:44:01 PM - Resolving predefined variables
5/22/19 3:44:01 PM - Resolving Test Steps to execute...
5/22/19 3:44:01 PM - Building test execution tree
5/22/19 3:44:01 PM - Test Suite "XXX" execution...
5/22/19 3:44:01 PM - Test Case: closeTmTcTestTool
5/22/19 3:44:01 PM - Step: prepare termination
5/22/19 3:44:01 PM - Step: alt+F4
5/22/19 3:44:03 PM - Step: Wait for Window
5/22/19 3:44:03 PM - Step: Click on dialog.button.ok ("OK")
!!Error occurred !!
Connection to AUT has been lost unexpectedly.
5/22/19 3:44:14 PM - Writing Report to Database
5/22/19 3:44:14 PM - Writing Report into file-system
5/22/19 3:44:14 PM - AUT Agent: connection closed.
5/22/19 3:44:14 PM - Exit: Code 1


I think that the problem is due to the confirmation windows (I can close in the same way without problems another AUT that doesn't have a confirmation window) but I don't know what to do to avoid/ignore it ...

I am working on linux sles 11 [2.6.32.12-0.7-default - x86_64] and Jubula 8.1.0.


thanks
Re: "Error occurred" closing a window [message #1807351 is a reply to message #1807103] Tue, 28 May 2019 11:31 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
Hello,

doing multiple actions after the prepare termination might lead to problems with the shutdown. Can you simply to a ENTER so the Application is clicked after the confirmation dialog? This might help in some Situations where the click might not work.

If this is not helping, it might be useful to have a look into the logs. They are located USER_HOME/.jubula/logs

best regards
Marvin Mueller
Re: "Error occurred" closing a window [message #1807359 is a reply to message #1807351] Tue, 28 May 2019 13:27 Go to previous messageGo to next message
Manuel GT is currently offline Manuel GTFriend
Messages: 5
Registered: May 2019
Junior Member
Hello

I am sorry but I really don't understand what you mean with:
"Can you simply to a ENTER so the Application is clicked after the confirmation dialog?"

I did this way:
5/28/19 1:24:44 PM - Test Case: closeTmTcTestTool
5/28/19 1:24:47 PM - Step: prepare termination
5/28/19 1:24:44 PM - Step: alt+F4
5/28/19 1:24:47 PM - Step: Wait for Window
5/28/19 1:24:47 PM - Step: TAB
5/28/19 1:24:47 PM - Step: ENTER
!!Error occurred !!
Connection to AUT has been lost unexpectedly.

to use the keyboard instead of the mouse pointer but nothing changed. The TAB is to move the focus from the 'Cancel' button to the 'OK' one.


The only thing that appear in the USER_HOME/.jubula/logs/client.log (other log files are untouched) is the following line:

2019-05-28 12:45:56.941 [Connection.ReaderThread:Socket[addr=/172.17.23.210,port=59529,localport=36073]] ERROR o.e.j.c.cmd.AbstractCmdlineClient - An error ocurred: Connection to AUT has been lost unexpectedly.
Re: "Error occurred" closing a window [message #1807367 is a reply to message #1807359] Tue, 28 May 2019 15:56 Go to previous message
Milos Hroudny is currently offline Milos HroudnyFriend
Messages: 21
Registered: June 2017
Junior Member
I would say that you close AUT during test. The connection is:
testexec <-> Agent <-> AUT
Your testcase closes AUT while testexec is executing test and this is a problem that is reported.
By my opinion you could create some batch file that will execute commands with wait for finishing.
It would contain calling testexec, then some sleep (about 10 seconds or more) and then command for closing your application if necessary.
Exclude from testcase closing AUT. This is not functionality that has to be tested.
Test can exercise what is necessary to test. After finishing last test step Jubula creates report and it takes some time (that is why I recommend put some sleep) and then kill your application. May also some other processing is possible but this works for me.
Actually if I use CLI, I use several bat scripts. But as an idea this could help.
Previous Topic:CZ keyboard - mapping of certain characters does not work
Next Topic:Exception with running Jubula-core on Eclipse
Goto Forum:
  


Current Time: Mon Nov 18 13:47:21 GMT 2019

Powered by FUDForum. Page generated in 0.02414 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top