Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Which Java version is recommended for Eclipse 2019-03(Wondering which version of Java is recommended from Oracle or if an Open JDK solution would suffice.)
Which Java version is recommended for Eclipse 2019-03 [message #1806866] Thu, 16 May 2019 16:00 Go to next message
Joshua Torres is currently offline Joshua TorresFriend
Messages: 1
Registered: May 2019
Junior Member
In my environment, we have a situation where we have the 32-bit and 64-bit versions of Java constantly being updated by a program called Ninite. We somehow missed the news that Oracle was moving to a paid licensing architecture and now all of the Java files that we have saved are 2MB large and only say that we need to purchase a license.
My question is, if we buy a license for a particular version of Java, what version is recommended for Eclipse 2019-03?
I am also wondering if any of the Open JDK/JRE's would be a good alternative to use as well.
Re: Which Java version is recommended for Eclipse 2019-03 [message #1806892 is a reply to message #1806866] Fri, 17 May 2019 08:22 Go to previous message
Ed Merks is currently online Ed MerksFriend
Messages: 30223
Registered: July 2009
Senior Member
Generally Java 8 works the best for most/all versions of Eclipse, including older ones. But if you want to use newer language/library features for Java development and need a newer version of Java for that purpose then newer versions should work with 2019-03 as well. I still mostly use Java 8 for all my IDEs. Probably open versions will work too, but that's not so well tested...
Previous Topic:Eclipse Install fails
Next Topic:Run EOL Standalone example
Goto Forum:
  


Current Time: Tue Jun 25 04:26:44 GMT 2019

Powered by FUDForum. Page generated in 0.03335 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top