Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » CDT doesn't start on Ubuntu 18.04(Standard installation won't start)
CDT doesn't start on Ubuntu 18.04 [message #1806821] Wed, 15 May 2019 16:39 Go to next message
Robert Bundy is currently offline Robert BundyFriend
Messages: 2
Registered: May 2019
Junior Member
I have made a clean install of Ubuntu 18.04 on an Up Board according to the instructions on the Up site. I then installed the latest java. When I issue the command "./eclipse/eclipse" the standard Eclipse Luna logo appears and then a popup appears that says: "An error has occurred. See the log file /home/bob/workspace/.metatdata/.log". The file is attached. The terminal output looks like this:

OpenJDK 64-Bit Server VM warning: Ignoring option MaxPermSize; support 
was removed in 8.0
Gtk-Message: 09:25:23.154: Failed to load module "canberra-gtk-module"
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by 
org.eclipse.osgi.storage.FrameworkExtensionInstaller 
(file:/home/bob/eclipse/plugins/org.eclipse.osgi_3.10.2.v20150203-1939.jar) 
to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of 
org.eclipse.osgi.storage.FrameworkExtensionInstaller
WARNING: Use --illegal-access=warn to enable warnings of further illegal 
reflective access operations
WARNING: All illegal access operations will be denied in a future release
Gtk-Message: 09:25:34.961: Failed to load module "canberra-gtk-module"


This installation has worked fine on Ubuntu 16.04 and earlier versions of Eclipse. I hope there is something simple I am missing here. Many thanks for anyone who can set me on the right track.
  • Attachment: .log
    (Size: 295.07KB, Downloaded 11 times)
Re: CDT doesn't start on Ubuntu 18.04 [message #1806822 is a reply to message #1806821] Wed, 15 May 2019 16:44 Go to previous messageGo to next message
Nitin Dahyabhai is currently online Nitin DahyabhaiFriend
Messages: 3439
Registered: July 2009
Senior Member

You are using an old version of Eclipse and a much newer version of Java. You should keep them somewhat concurrent.

https://www.eclipse.org/forums/index.php/t/198527/


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: CDT doesn't start on Ubuntu 18.04 [message #1806830 is a reply to message #1806822] Wed, 15 May 2019 22:30 Go to previous message
Robert Bundy is currently offline Robert BundyFriend
Messages: 2
Registered: May 2019
Junior Member
Works! Thanks. Sorry, I should have figured this out. I just followed a Google result for "Install Eclipse C++" which led me down the wrong path.
Previous Topic:Updating: Missing org.osgi.service.event.EventAdmin
Next Topic:Moderated Post
Goto Forum:
  


Current Time: Sun Jul 21 21:56:25 GMT 2019

Powered by FUDForum. Page generated in 0.03067 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top