Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Tomcat 8.5 WAR deployment(Deployment)
Tomcat 8.5 WAR deployment [message #1806102] Thu, 02 May 2019 16:10 Go to next message
Jean-Pascal Laux is currently offline Jean-Pascal LauxFriend
Messages: 55
Registered: December 2011
Member
Hello,

I spent a lot of hours to deploy my WAR with Tomcat 8.5 without success.
I always have error : Unresolved requirement: Import-Package: jaxvax.servlet; version="[3.1.0,5.0.0)" for several plugins (my plugins and RAP plugins)
After a lot search on Internet, I found the bug 545682 so I downloaded the latest version of org.eclipse.equinox.servletbridge : org.eclipse.equinox.servletbridge_1.5.0.v20190405-1333.jar
I put the jar in Plugins and lib directories but I still have an error

It is very annoying.
Could you help me ?
Thanks
Kind regards
Jean-Pascal
Re: Tomcat 8.5 WAR deployment [message #1806106 is a reply to message #1806102] Thu, 02 May 2019 16:53 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2327
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
replacing the servletbridge jar should do the trick. Nevertheless, we released 3.8.1 Service Release to address this issue. Please download RAP 3.8.1 from [1]

[1] https://www.eclipse.org/rap/downloads/

Best regards,
Ivan
Previous Topic:Starting RAP e4 app failed
Next Topic:Test automation for RAP-based application using HP/Microfocus UFT
Goto Forum:
  


Current Time: Sun Dec 15 02:24:54 GMT 2019

Powered by FUDForum. Page generated in 0.02042 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top