Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » XText 2.17 + eclipse 2019-03 + maven build problem(Maven Build )
XText 2.17 + eclipse 2019-03 + maven build problem [message #1805717] Mon, 22 April 2019 16:19 Go to next message
Alex Gor is currently offline Alex GorFriend
Messages: 145
Registered: November 2014
Location: Russia
Senior Member
Hello all


in case I create simple xtext project with maven as based builder and try to build. The following error is observed.

[ERROR] Failed to resolve target definition C:\Users\agorlov\Documents\projects\workspaces\flexprod\atom\dev_6.400.00_FXPST_27656\implementaion\com.psl.atom.target\com.psl.atom.target.target: Failed to load p2 metadata repository from location http://download.eclipse.org/releases/2019-03: Unable to read repository at http://download.eclipse.org/releases/2019-03. Unable to connect to repository https://download.eclipse.org/technology/epp/packages/2019-03/content.xml: Connection timed out: connect -> [Help 1]

In case I changed
<repository location="http://download.eclipse.org/releases/2019-03/" />

to

<repository location="http://download.eclipse.org/releases/2019-03/201903201000" />

The error is disappeared. Is it correct correction?


[Updated on: Mon, 22 April 2019 16:20]

Report message to a moderator

Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805718 is a reply to message #1805717] Mon, 22 April 2019 17:07 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13163
Registered: July 2009
Senior Member
http://download.eclipse.org/releases/2019-03/ is the correct location.
it may always be that eclipse servers have a bad day.
(you should open a bugzilla if problem persists for a longer day)

http://download.eclipse.org/releases/2019-03/201903201000
is also correct but does not include the stuff from the epp packages update site


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805720 is a reply to message #1805718] Mon, 22 April 2019 17:56 Go to previous messageGo to next message
Alex Gor is currently offline Alex GorFriend
Messages: 145
Registered: November 2014
Location: Russia
Senior Member
By the way the story with

<unit id="org.junit" version="4.12.0.v201504281640"/>
<unit id="org.junit.jupiter.api" version="5.4.0.v20190212-2109"/>
<unit id="org.junit.jupiter.engine" version="5.4.0.v20190212-2109"/>
<unit id="org.junit.platform.commons" version="1.4.0.v20190212-2109"/>
<unit id="org.junit.platform.engine" version="1.4.0.v20190212-2109"/>
<unit id="org.junit.platform.launcher" version="1.4.0.v20190212-2109"/>
<unit id="org.junit.platform.runner" version="1.4.0.v20190212-2109"/>

I cannot find it on http://download.eclipse.org/modeling/tmf/xtext/updates/orbit/2019-03

Could you help me?

I try to open the site via "Install new software" feature and enter pattern junit

[ERROR] Failed to resolve target definition C:\Users\agorlov\Documents\projects\workspaces\flexprod\atom\dev_6.400.00_FXPST_27656\implementaion\com.psl.atom.target\com.psl.atom.target.target: Could not find "org.junit.jupiter.api/5.3.1.v201
81005-1442" in the repositories of the current location -> [Help 1]

[Updated on: Mon, 22 April 2019 18:06]

Report message to a moderator

Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805725 is a reply to message #1805720] Mon, 22 April 2019 18:32 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13163
Registered: July 2009
Senior Member
Please try to hit the reload button
Our open a bug against eclipse download servers


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805726 is a reply to message #1805725] Mon, 22 April 2019 18:34 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13163
Registered: July 2009
Senior Member
also make sure that you use a otbit update site that matches stuff.
you can find many releases here
https://download.eclipse.org/tools/orbit/downloads/
and they all contain different versions for different eclipse versions

https://download.eclipse.org/modeling/tmf/xtext/updates/orbit/2019-03/compositeContent.xml
forwards to
https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository/
(see https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/ for a list of contents)

there is no 5.3.1


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Mon, 22 April 2019 18:37]

Report message to a moderator

Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805742 is a reply to message #1805726] Tue, 23 April 2019 04:21 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
Note that you can use the Repository Explorer to find an Eclipse-hosted update site for a specific installable unit version:

https://wiki.eclipse.org/Eclipse_Oomph_Authoring#How_to_find_a_P2_repository_at_Eclipse_using_the_Repository_Explorer
Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805743 is a reply to message #1805726] Tue, 23 April 2019 04:38 Go to previous messageGo to next message
Alex Gor is currently offline Alex GorFriend
Messages: 145
Registered: November 2014
Location: Russia
Senior Member
Always, I use a simple project after migration to a new version of eclipse and XText for smoke testing. All links to repositories are generated or saved by XText. Maybe my eclipse distribution is not up to date.

In any case, thank you for support
Re: XText 2.17 + eclipse 2019-03 + maven build problem [message #1805745 is a reply to message #1805743] Tue, 23 April 2019 05:50 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13163
Registered: July 2009
Senior Member
maybe simply a server was down

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Terminal rules vs parser rules priority
Next Topic:On adding XtextAntlrGeneratorFragment2 in Workflow .Iam getting exception
Goto Forum:
  


Current Time: Mon Oct 21 04:41:31 GMT 2019

Powered by FUDForum. Page generated in 0.02055 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top