Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » TFS Plugin on OSX(TFS plugin installs but never becomes visible in view or perspectives)
TFS Plugin on OSX [message #1805609] Thu, 18 April 2019 16:10 Go to next message
Albert Spohn is currently offline Albert SpohnFriend
Messages: 1
Registered: April 2019
Junior Member
I'm a new Eclipse user looking to hook up Eclipse with our institutional TFS/Git environment. I'm running Mac OSX (10.12.6) and Eclipse (2019-03 (4.11.0)) and was looking to install the MS TFS plugin, using the following various instructions, e.g., via Marketplace, via New Software and local installation from a Zip file (TFSEclipsePlugin-UpdateSiteArchive-14.134.0.zip). All installations ran without a hitch.

Everything goes as advertised, but when I restart as directed, I am never able to get the plugin to appear either in a View or a Perspective. When I try to reinstall, it tells me it is already installed.

If I look in plugs tab of my workspace, I can see something like 29 TFS items installed. I also see "Team Explorer" under the software tab under "About Eclipse/Installation details" - but it doesn't appear under the plug-ins tab in that dialog.

I've tried installing through Marketplace, locally with a zip file and via "New software" - all installations run with no errors, but the plugin just never appears as a View or Perspective.

Any suggestions on getting this into a useable state (i.e., as a view or perspective) would be greatly appreciated!

Thanks in advance, Al

P.S. Actually I finally found the error log, and there were indeed errors. Each component of the TFS Plug-in had a line similar to this one:

!MESSAGE Failed to find a configured bundleInfo for: [R]com.microsoft.tfs.checkinpolicies 14.134.0.201804261732.

[Updated on: Thu, 18 April 2019 19:11]

Report message to a moderator

Re: TFS Plugin on OSX [message #1805619 is a reply to message #1805609] Fri, 19 April 2019 03:58 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30141
Registered: July 2009
Senior Member
It seems to be a Github project so likely you'd be best to ask on their issues tracker:

https://github.com/Microsoft/team-explorer-everywhere/issues
Previous Topic:IDE GIT throws an exception when I try to import certain repos
Next Topic:Installer installs Oxygen not 2019-03
Goto Forum:
  


Current Time: Sun May 26 22:07:19 GMT 2019

Powered by FUDForum. Page generated in 0.03250 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top