Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Starting RAP e4 app failed
Starting RAP e4 app failed [message #1805439] Mon, 15 April 2019 10:15 Go to next message
Olaf van der Meer is currently offline Olaf van der MeerFriend
Messages: 4
Registered: April 2019
Junior Member
Hi,

I'm new to RAP development and try to start with it. I found this tutorial:
https://o7planning.org/en/10183/eclipse-rap-tutorial-for-beginners-workbench-application#a756410

I followed the complete tutorial twice and picked all the latest versions.

Running the application failed:

!SESSION 2019-04-15 12:07:36.086 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=nl_NL
Framework arguments:  -application org.eclipse.ui.ide.workbench
Command-line arguments:  -application org.eclipse.ui.ide.workbench -data D:\Projects\WorkspaceEclipseRAP_E4/../runtime-EclipseApplication -dev file:D:/Projects/WorkspaceEclipseRAP_E4/.metadata/.plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.e4.ui.workbench.addons.swt 4 0 2019-04-15 12:07:36.541
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.addons.swt [182]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.renderers.swt; bundle-version="0.9.1"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.renderers.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
       org.eclipse.e4.ui.workbench.renderers.swt [184]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
              org.eclipse.e4.ui.workbench.swt [187]
                Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds
  Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
    -> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.13.0.rap-20170607-0603"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"

	at org.eclipse.osgi.container.Module.start(Module.java:452)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1784)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1763)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1726)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1657)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:233)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:343)

!ENTRY org.eclipse.e4.ui.workbench.renderers.swt 4 0 2019-04-15 12:07:36.543
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt [184]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
       org.eclipse.e4.ui.workbench.swt [187]
         Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds

	at org.eclipse.osgi.container.Module.start(Module.java:452)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1784)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1763)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1726)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1657)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:233)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:343)

!ENTRY org.eclipse.e4.ui.workbench.swt 4 0 2019-04-15 12:07:36.543
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.swt [187]
  Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds

	at org.eclipse.osgi.container.Module.start(Module.java:452)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1784)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1763)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1726)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1657)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:233)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:343)

!ENTRY org.eclipse.rap.e4 4 0 2019-04-15 12:07:36.544
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rap.e4 [205]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
       org.eclipse.e4.ui.workbench.swt [187]
         Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds

	at org.eclipse.osgi.container.Module.start(Module.java:452)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1784)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1763)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1726)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1657)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:233)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:343)

!ENTRY RAPe4Tutotial 4 0 2019-04-15 12:07:36.544
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: RAPe4Tutotial [227]
  Unresolved requirement: Require-Bundle: org.eclipse.rap.e4; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.rap.e4; bundle-version="0.9.0.rap-20170607-0603"
       org.eclipse.rap.e4 [205]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
              org.eclipse.e4.ui.workbench.swt [187]
                Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds

	at org.eclipse.osgi.container.Module.start(Module.java:452)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1784)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1763)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1726)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1657)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:233)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:343)

!ENTRY org.eclipse.e4.ui.workbench.swt 2 0 2019-04-15 12:07:36.701
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.swt [187]
  Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds


!ENTRY org.eclipse.rap.e4 2 0 2019-04-15 12:07:36.702
!MESSAGE Could not resolve module: org.eclipse.rap.e4 [205]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
       org.eclipse.e4.ui.workbench.swt [187]
         Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds


!ENTRY org.eclipse.e4.ui.workbench.renderers.swt 2 0 2019-04-15 12:07:36.702
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt [184]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
       org.eclipse.e4.ui.workbench.swt [187]
         Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds


!ENTRY RAPe4Tutotial 2 0 2019-04-15 12:07:36.703
!MESSAGE Could not resolve module: RAPe4Tutotial [227]
  Unresolved requirement: Require-Bundle: org.eclipse.rap.e4; bundle-version="0.9.0"
    -> Bundle-SymbolicName: org.eclipse.rap.e4; bundle-version="0.9.0.rap-20170607-0603"
       org.eclipse.rap.e4 [205]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.12.100"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
              org.eclipse.e4.ui.workbench.swt [187]
                Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds


!ENTRY org.eclipse.e4.ui.workbench.addons.swt 2 0 2019-04-15 12:07:36.704
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.addons.swt [182]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.renderers.swt; bundle-version="0.9.1"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.renderers.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
       org.eclipse.e4.ui.workbench.renderers.swt [184]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench.swt; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench.swt; bundle-version="0.13.0.rap-20170607-0603"; singleton:="true"
              org.eclipse.e4.ui.workbench.swt [187]
                Unresolved requirement: Require-Bundle: org.eclipse.equinox.ds
  Unresolved requirement: Import-Package: org.eclipse.e4.ui.internal.workbench.swt
    -> Export-Package: org.eclipse.e4.ui.internal.workbench.swt; bundle-symbolic-name="org.eclipse.e4.ui.workbench.swt"; bundle-version="0.13.0.rap-20170607-0603"; version="0.0.0"; x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.e4.ui.workbench.renderers.swt,org.eclipse.ui.workbench"


!ENTRY org.eclipse.osgi 4 0 2019-04-15 12:07:36.704
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.rap.demo.application.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:252)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:33)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:661)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1476)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1449)


Any idea's how to fix this?
Re: Starting RAP e4 app failed [message #1805759 is a reply to message #1805439] Tue, 23 April 2019 08:59 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2327
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
did you setup RAP e4 target platform from [1]? Please show the output of OSGi "ss" command.

[1] https://www.eclipse.org/rap/downloads/

Regards,
Ivan
Previous Topic:composite or canvas to image or imagedata
Next Topic:Tomcat 8.5 WAR deployment
Goto Forum:
  


Current Time: Thu Dec 05 23:07:54 GMT 2019

Powered by FUDForum. Page generated in 0.02281 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top