Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » force.com IDE new project doesn't work - help please(I cannot create a new project on the force.com IDE )
force.com IDE new project doesn't work - help please [message #1805364] Fri, 12 April 2019 16:29 Go to next message
Stav Greenberg is currently offline Stav GreenbergFriend
Messages: 2
Registered: April 2019
Junior Member
When Icreate a new force.com project I cannot go through the first step.
After filling out the project details , token and credentials - The NEXT button doesn't do any thing,

Re: force.com IDE new project doesn't work - help please [message #1805368 is a reply to message #1805364] Fri, 12 April 2019 16:46 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3528
Registered: July 2009
Senior Member

You should contact support through Salesforce. Force.com is not provided by eclipse.org.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: force.com IDE new project doesn't work - help please [message #1805373 is a reply to message #1805368] Fri, 12 April 2019 17:33 Go to previous messageGo to next message
Stav Greenberg is currently offline Stav GreenbergFriend
Messages: 2
Registered: April 2019
Junior Member
Thanks!

I did find in SF forums a description of this problem and the only solution suggested was installing the older Oxygen version of eclipse.

I am trying it but when I lunch eclipse on the oxygen version I get an error referring me to the log.

Can you help?
Here is what I get from the log :

!ENTRY org.eclipse.e4.ui.workbench 4 0 2019-04-12 14:30:50.251
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:450)
at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:156)
at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:178)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:99)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:141)
at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:908)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:168)
at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
at org.eclipse.osgi.container.Module.doStop(Module.java:634)
at org.eclipse.osgi.container.Module.stop(Module.java:498)
at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 21 more
Re: force.com IDE new project doesn't work - help please [message #1805385 is a reply to message #1805373] Sat, 13 April 2019 02:14 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3528
Registered: July 2009
Senior Member

Releases older than Oxygen.1a don't properly work with Java 9/10/11 without incident. Check https://www.eclipse.org/forums/index.php/t/198527/ .

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Eclipse application won't run with OpenJDK 11
Next Topic:Can't install Eclipse on Ubuntu
Goto Forum:
  


Current Time: Thu Nov 21 15:52:49 GMT 2019

Powered by FUDForum. Page generated in 0.03089 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top