Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Referenced versions in xtext-dev-bom
Referenced versions in xtext-dev-bom [message #1804255] Thu, 21 March 2019 09:57 Go to next message
Michael Bischoff is currently offline Michael BischoffFriend
Messages: 13
Registered: August 2012
Junior Member
Hello,
if I include this bom, and then do a
mvn versions:display-plugin-updates

I see suggestions to update to newer releases:
[INFO]   org.eclipse.emf:org.eclipse.emf.codegen ............. 2.11.0 -> 2.14.0
[INFO]   org.eclipse.emf:org.eclipse.emf.codegen.ecore ....... 2.12.0 -> 2.15.0
[INFO]   org.eclipse.emf:org.eclipse.emf.common .............. 2.12.0 -> 2.15.0
[INFO]   org.eclipse.emf:org.eclipse.emf.ecore ............... 2.12.0 -> 2.15.0
[INFO]   org.eclipse.emf:org.eclipse.emf.ecore.change ........ 2.11.0 -> 2.13.0
[INFO]   org.eclipse.emf:org.eclipse.emf.ecore.xmi ........... 2.12.0 -> 2.15.0

Is there a reason why the older ones have been referenced?
Or, will I get issues if I add dependency management for the newer releases before I import xtext-dev-bom (effectively overriding the definitions of that)?

Best regards,
Michael
Re: Referenced versions in xtext-dev-bom [message #1804256 is a reply to message #1804255] Thu, 21 March 2019 09:58 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13062
Registered: July 2009
Senior Member
yes cause noone worked on https://github.com/eclipse/xtext/issues/1282
the versions mentioned there are the only ones we supported and are used intentionally.
all newer versioned pulled are caused by maven pulling the world cause of conflicts/ranges of death in older xtext and current platform versions


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Thu, 21 March 2019 09:59]

Report message to a moderator

Re: Referenced versions in xtext-dev-bom [message #1804266 is a reply to message #1804256] Thu, 21 March 2019 14:37 Go to previous messageGo to next message
Michael Bischoff is currently offline Michael BischoffFriend
Messages: 13
Registered: August 2012
Junior Member
Hi,
thanks, I will use those then. I had assumed we need the newer ones to support JDK 11.

Best regards,
Michael
Re: Referenced versions in xtext-dev-bom [message #1804271 is a reply to message #1804266] Thu, 21 March 2019 16:25 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13062
Registered: July 2009
Senior Member
let us know if you find any issues

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:XTEXT Custom Content Assist
Next Topic:[Xbase] Classloading in XbaseInterpreter
Goto Forum:
  


Current Time: Sun Aug 18 10:44:49 GMT 2019

Powered by FUDForum. Page generated in 0.02039 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top