Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Which eclipse version will be bundled with efxclipse 3.5?
Which eclipse version will be bundled with efxclipse 3.5? [message #1802401] Fri, 08 February 2019 09:49 Go to next message
Thomas Fahrmeyer is currently offline Thomas FahrmeyerFriend
Messages: 30
Registered: July 2009
Location: Germany
Member
Hi,

I'm just discovered the Eclipse enhancement ticket that adds a new valuable method:
EModelService#deleteElement(element)


See Bug and Commit for further information.

This will be integrated into org.eclipse.e4.ui.workbench-1.9.0.x. So there comes questions into my mind:

* in which module of efxclipse-rt is the dependency to the eclipse version be defined?
* I found releng/org.eclipse.fx.target.ext.releng/pom.xml
* there is a property platform.version which is nowhere used and a p2 repository "oxygen.0 pointing to http://download.eclipse.org/eclipse/updates/4.9/R-4.9-201809060745/. That seems the exclipse version which is bundled, isn't?
* when will that version be part of efxclipse bundled eclipse version?
Re: Which eclipse version will be bundled with efxclipse 3.5? [message #1802433 is a reply to message #1802401] Fri, 08 February 2019 18:23 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6505
Registered: July 2009
Senior Member
Right you found the correct place where the upstream version is configured. Our build is done in 2 steps:
* building our target
* builing the platform

Our current upstream target is 2018-09 - we only update immediately to upstream if there are important features we or one of our (paying) customers want/need because of the chances to inherit upstream bugs (we got hit by them multiple times already!).

2018-09 was an important release because of the Java-11 support in equinox. I don't see a reason to update to 2018-12 at the moment and the new feature you are interested in is part of 2019-03 which is post our 3.5 release. . Maybe we'll update to this release with our 3.6 update but I can not promise it will happen as there's risk involved that we'll have to fix problems nobody is paying us for.
Previous Topic:Is there an approximate release date for efxclipse 3.5?
Next Topic:OpenJDK with e(fx)clipse
Goto Forum:
  


Current Time: Fri Sep 20 07:49:31 GMT 2019

Powered by FUDForum. Page generated in 0.06930 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top