Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Build not configured correctly(Error message "Build not configured correctly" on Eclipse Cpp 2018-12 (Windows 10))
Build not configured correctly [message #1802392] Fri, 08 February 2019 00:27 Go to next message
Jerome MORE is currently offline Jerome MOREFriend
Messages: 1
Registered: February 2019
Junior Member
Hello everybody,

I recently installed Eclipse Cpp 2018-12 and MinGW under Windows 10, but I am having a hard time configuring it, and I always have this silly message :
"Build not configured correctly".
Which means that I could never reach the simple point of having a hello world program running, even after having spent hours on several forums and videos. Most of the explanations I have found so far could never really help, as they seem to refer to older versions of Eclipse, which is useless in my case as apparently many menu options have been removed or changed.

So I will try to describe as precisely as possible my problem:

Installation:
I downloaded "Eclipse IDE for C/C++ Developers" (2018-12) from the official site, then installed it under. The main file is here:
C:\Users\Jerome\eclipse\cpp-2018-12\eclipse\eclipse.exe

Then I downloaded MinGW from sourceforge and installed here:
C:\MinGW

Following some advice, I appended to the windows environment variable "Path" the proper bin folder for MinGW:
C:\MinGW\bin
I did it both for system variable and user variable, to be sure (as Eclipse is installed under my user account)
Of course, I restarted my computer then.

Then about Eclipse configuration itself, I am getting confused about all the possible options and menus. So trying to reproduce what I read in the forums, I went to:
Window/Preferences/C++/New C++ Project Wizard
For almost all project types, I chose:
toolchain: MinGW GCC.
Then:
Make toolchain(s) preferred
I also tried to uncheck:
Show Project types and toolchains only if they are supported on the platform.
However it seems to automatically check back on again, so I didn't insist.

I also tried to go to:
Window/Preferences/C++/Build/Build variables
then add the variable "Path"
which as far as I understood refers to the corresponding windows environment variable.
But that didn't have any further effect.

Finally, I just tried to create the simplest project:
File/New/C C++ Project
CMake
Empty of Existing CMake Project
New/File
main.cpp
putting inside it just:
int main() {}

Then whenever I try to built it, I have this error message:
Build not configured correctly.

And same story with other kind of project types.

I didn't do any change in the Project properties, as again the only suggestions I have found so far refer to options that don't exist anymore.

So if I understood correctly, all the issue is about having MinGW compiler linked to Eclipse properly, but the advice I followed didn't work so far. I kind of feel I missed something possibly simple in that story, but I am not able to tell what.

I would really appreciate your help on that topic !
Re: Build not configured correctly [message #1808052 is a reply to message #1802392] Fri, 14 June 2019 22:32 Go to previous messageGo to next message
Paul Swoboda is currently offline Paul SwobodaFriend
Messages: 1
Registered: June 2019
Junior Member
I am seeing the same phenomenon with 2018-12 and a basic C++ Makefile project.
Re: Build not configured correctly [message #1815551 is a reply to message #1808052] Fri, 04 October 2019 16:40 Go to previous messageGo to next message
Carl Wilburn is currently offline Carl WilburnFriend
Messages: 1
Registered: October 2019
Junior Member
Seeing the same as you and Jerome. I will look further through messages, but total lack of response makes me wonder if Eclipse/C++ is not being supported.

Did you get an answer?
Re: Build not configured correctly [message #1815663 is a reply to message #1815551] Tue, 08 October 2019 05:23 Go to previous messageGo to next message
David VavraFriend
Messages: 1377
Registered: October 2012
Senior Member
I've had this happen recently with a CMake project.
The problem was in the CMake setup which really has nothing to do with Eclipse.
Went away when I reconstructed the project with the proper setup.
I had to delete the Eclipse project files and re-import the project after fixing the CMake setup.

I notice the OP also was using CMake.
Too bad he didn't post how he got around the problem.

ASIDE: I don't know why but posts rarely update for me over the weekend
and suddenly appear on Mondays and sometimes Tuesdays.

[Updated on: Tue, 08 October 2019 05:50]

Report message to a moderator

Re: Build not configured correctly [message #1830396 is a reply to message #1815663] Fri, 24 July 2020 16:42 Go to previous messageGo to next message
Roshan Shah is currently offline Roshan ShahFriend
Messages: 1
Registered: July 2020
Junior Member
I had this issue for a long time and I think I've got it working now. PS fairly sure the only thing you need to do is the first part below i.e. go to the other projects menu.

The post by Jerome was really useful as I had tried that stuff as well and summed up the steps pretty well.
My fix was to not use the new way of getting projects from eclipse (recent eclipse updates). I did:
File->New->Other->C++ project->Executable->"Hello World C++ Project" + Click "MinGW GCC" under toolchains + give project name-> finish (or next)
The build project and run - it should work and give hello world.

But before this you must do a few checks (note: the Eclipse help function is out of date and menus keep moving around all the time)
1) Correct binary Parsers. Go to Window->Preferences->"New C++ Project Wizard" click on drop own arrow->Makefile Project->PE64 Windows Parser ticked and moved to the top->apply and close->restart eclipse
2) Check MinGW path. On computer go to environment variables (advanced system settings), under system variables go to path and edit, move/add "C:\MinGW\bin" to the top. Had issues with admin/user account so also added this to the user variables path - optional but shouldn't hurt (from what I know). Restarted computer. And check MinGW installed using cmd window: "g++ --version"
3) I did the things from Jerome's post: a) Make MinGW the preferred toolchain for everything b) Window/Preferences/C++/Build/Build variables then add the variable "Path" (this just confirmed that the environment variables were being read - can see all environmental variables but unticking box) c) tried other default C++ project types (these failed)

Anyways, if you choose the project through the "Other" menu then you should be good to go and have no issues. I think this is a silly windows eclipse issue that doesn't exist on Mac but I may be wrong.

Hope that helps!
Re: Build not configured correctly [message #1833513 is a reply to message #1802392] Thu, 15 October 2020 11:33 Go to previous messageGo to next message
Michał Szwejkowski is currently offline Michał SzwejkowskiFriend
Messages: 1
Registered: October 2020
Junior Member
Yeah, unfortunately could not fix this otherwise than deleting project and creating it over existing sources again. Remember to manually delete .project, .cproject files and .settings from jour sources folder, otherwise all wrong settings get into project again!

If you have a lot of settings in "Paths and Symbols" you can export it to file and then easily import back.
Re: Build not configured correctly [message #1847199 is a reply to message #1815551] Tue, 19 October 2021 08:17 Go to previous messageGo to next message
Promodkumar CM is currently offline Promodkumar CMFriend
Messages: 8
Registered: September 2020
Junior Member
Hi, @David VavraFriend I'm also having the same issue with CMAKE and eclipse.
I have installed CMake and added path in the windows path variable but it still showing "Build not configured correctly" when building a new CMake project in eclipse.
could you please mention the steps to fix the issue with CMake and eclipse to build the project? Thanks in advance.
Re: Build not configured correctly [message #1847204 is a reply to message #1847199] Tue, 19 October 2021 09:58 Go to previous message
David VavraFriend
Messages: 1377
Registered: October 2012
Senior Member
Frankly, I don't remember what the problem actually was or how I got around it.
I rarely (as in never) use CMake so haven't had a recurrence.
I just tried a quickie HelloWorld using CMake and it built fine.

FWIW: I'm using 2021-09

[Updated on: Tue, 19 October 2021 10:03]

Report message to a moderator

Previous Topic:Debugging with GDB - incorrect path to executable
Next Topic:Remove double quotes from build command
Goto Forum:
  


Current Time: Fri Oct 22 13:18:25 GMT 2021

Powered by FUDForum. Page generated in 0.01850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top