Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Representation diagram in Tree Description(how to activate a representation diagram in the tree description)
Representation diagram in Tree Description [message #1801317] Wed, 16 January 2019 16:00 Go to next message
Marc Donald  Tala is currently offline Marc Donald TalaFriend
Messages: 6
Registered: April 2018
Junior Member
Hallo,

i have defined a tree description of a project (named Core). The Core metamodel extends Hardware metamodel and Software metamodel. From the tree Core, i can create a new representation diagram either for Harware model or for Software model.

Now i want to make this representation diagram available in the tree Core (like in the picture).

Is there a way to do that in the Tree Description?

Thanks

Marc

[Updated on: Wed, 16 January 2019 16:02]

Report message to a moderator

Re: Representation diagram in Tree Description [message #1801399 is a reply to message #1801317] Fri, 18 January 2019 09:08 Go to previous messageGo to next message
Florian Barbin is currently offline Florian BarbinFriend
Messages: 227
Registered: August 2010
Senior Member
Hi,

In your screenshot, the diagram displayed in the model explorer just means that a diagram based on the Family model element has been created. If you have defined a new Tree representation in your odesign, it will be displayed in this tree once you have created a new Tree based on the description in the odesign.

Regards,

Florian
Re: Representation diagram in Tree Description [message #1801508 is a reply to message #1801399] Mon, 21 January 2019 12:08 Go to previous message
Marc Donald  Tala is currently offline Marc Donald TalaFriend
Messages: 6
Registered: April 2018
Junior Member
Hi Florian,

Thanks for your answer, but what i want, is to navigate to a diagram from a tree description. With the navigation operation i can do it. Now i want that the symbol of the diagram can be seen in the tree.

Regards,

Marc
Previous Topic:Inconsistency after deleting element based edge
Next Topic:Custom Diagram Layout ('arrange-all') does not work as expected
Goto Forum:
  


Current Time: Fri Aug 23 14:03:21 GMT 2019

Powered by FUDForum. Page generated in 0.01561 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top