Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Problem with latest 2018-12 SimRel and Oomph
Problem with latest 2018-12 SimRel and Oomph [message #1800090] Wed, 19 December 2018 18:30 Go to next message
Mike Norman is currently offline Mike NormanFriend
Messages: 6
Registered: July 2012
Junior Member
I have a setup that is working with 2018-09 SimRel update sites.

This morning I tried updating it for the new 2018-12 SimRel

...
    <setupTask
        xsi:type="setup.p2:P2Task"
        label="Eclipse IDE for Java EE Developers (2018-12)">
      <requirement
          name="epp.package.jee"/>

...
      <repository
          url="http://download.eclipse.org/technology/epp/packages/2018-12"/>
      <repository
          url="http://download.eclipse.org/releases/2018-12"/>
    </setupTask>


and received the following error message:

[2018-12-19 13:24:01] ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:425)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:337)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:733)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3334)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3262)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3243)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3143)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1545243835585
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: artificial_root 1.0.0.v1545243835585 requires 'org.eclipse.equinox.p2.iu; org.eclipse.jpt.dbws.eclipselink.feature.feature.group 0.0.0' but it could not be found


I don't think the EclipseLink DBWS feature group is at fault, I'm guessing the first artifact 'org.eclipse.equinox.p2.iu' should probably be 'org.eclipse.equinox.p2.ui'
Re: Problem with latest 2018-12 SimRel and Oomph [message #1800108 is a reply to message #1800090] Thu, 20 December 2018 05:20 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30439
Registered: July 2009
Senior Member
Mike, that feature was removed from the 2018-12 packages and train and hence was removed from the generated Product Catalog:

https://git.eclipse.org/c/oomph/org.eclipse.oomph.git/commit/?id=430f72f7c66b337175c7a6ff680226dafc305a09

Perhaps you tried this using an older cached version of the setups.zip?

What exactly did you do?
Re: Problem with latest 2018-12 SimRel and Oomph [message #1800175 is a reply to message #1800108] Thu, 20 December 2018 22:42 Go to previous message
Mike Norman is currently offline Mike NormanFriend
Messages: 6
Registered: July 2012
Junior Member
Yeah, I finally figured out that part (and as the author of DBWS,
you-aint-missin-much ;-) !!)

The other part was that something the Payara Tools relies
on is now delivered via a separate P2Task ... took a bit of
to-ing-&-fro-ing to find the feature group name and versions.
Once I did that (Sapphire Java Developer Support and Sapphire
XML Editor Support) I got a modified version of my user.setup
to re-create the Oomph settings I had working in 2018-09 in
2018-12

Needless to say, the error messages did not point me in the right direction :-(
Previous Topic:Purpose of branding info
Next Topic:Unexpected location for eclipse configuration information
Goto Forum:
  


Current Time: Sun Sep 15 18:54:27 GMT 2019

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top