Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Oomph Setups.zip outdated?
Oomph Setups.zip outdated? [message #1799910] Mon, 17 December 2018 10:53 Go to next message
Patrick Bänziger is currently offline Patrick BänzigerFriend
Messages: 89
Registered: September 2011
Member
Hi there

I'm a committer on the Eclipse Scout project.

We provide a Setup file (https://git.eclipse.org/c/scout/oomph.git/plain/Scout.setup) that is collected by Oomph and is available in the Installer dialogues.

We've noticed that some of the changes that we made don't get synced into the public Setups.zip file (https://download.eclipse.org/oomph/www/setups.zip).

Specifically, we had a bug in our Setup-file where the stream labeled "SimRel 2018-12" pointed to the URL with build 30 (http://download.eclipse.org/scout/releases/8.0/8.0.0/030_Simrel_2018_12/).

We've changed that more than 36hours ago to build 31 (...031_Simrel_2018_12/), but the Setups.zip file still shows the old URL.

I've noticed that the setup-archiver job, while green, contains warnings...
Is that an issue you can fix or something that went wrong on our end?

Regards,
Patrick

!SESSION 2018-12-17 05:50:08.645 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_192
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -application org.eclipse.oomph.setup.core.SetupArchiver -target /home/data/httpd/download.eclipse.org/oomph/www/setups.zip
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data @noDefault -application org.eclipse.oomph.setup.core.SetupArchiver -consoleLog -target /home/data/httpd/download.eclipse.org/oomph/www/setups.zip

!ENTRY org.eclipse.core.net 1 0 2018-12-17 05:50:11.131
!MESSAGE System property http.proxyHost is not set but should be proxy.eclipse.org.

!ENTRY org.eclipse.core.net 1 0 2018-12-17 05:50:11.131
!MESSAGE System property http.proxyPort is not set but should be 9898.

!ENTRY org.eclipse.core.net 1 0 2018-12-17 05:50:11.131
!MESSAGE System property https.proxyHost is not set but should be proxy.eclipse.org.

!ENTRY org.eclipse.core.net 1 0 2018-12-17 05:50:11.132
!MESSAGE System property https.proxyPort is not set but should be 9898.

!ENTRY org.eclipse.core.net 1 0 2018-12-17 05:50:11.133
!MESSAGE System property https.proxyHost is not set but should be proxy.eclipse.org.

!ENTRY org.eclipse.core.net 1 0 2018-12-17 05:50:11.134
!MESSAGE System property https.proxyPort is not set but should be 9898.
Dec 17, 2018 5:50:14 AM org.eclipse.ecf.provider.filetransfer.httpclient4.SNIAwareHttpClient tryConnect
INFO: I/O exception (java.net.NoRouteToHostException) caught when connecting to {}->http://proxy.eclipse.org:9898->http://git.eclipse.org:80: No route to host (Host unreachable)
Dec 17, 2018 5:50:14 AM org.eclipse.ecf.provider.filetransfer.httpclient4.SNIAwareHttpClient tryConnect
INFO: Retrying connect to {}->http://proxy.eclipse.org:9898->http://git.eclipse.org:80
Dec 17, 2018 5:50:17 AM org.eclipse.ecf.provider.filetransfer.httpclient4.SNIAwareHttpClient tryConnect
INFO: I/O exception (java.net.NoRouteToHostException) caught when connecting to {}->http://proxy.eclipse.org:9898->http://git.eclipse.org:80: No route to host (Host unreachable)
Dec 17, 2018 5:50:17 AM org.eclipse.ecf.provider.filetransfer.httpclient4.SNIAwareHttpClient tryConnect
INFO: Retrying connect to {}->http://proxy.eclipse.org:9898->http://git.eclipse.org:80
Dec 17, 2018 5:50:20 AM org.eclipse.ecf.provider.filetransfer.httpclient4.SNIAwareHttpClient tryConnect
INFO: I/O exception (java.net.NoRouteToHostException) caught when connecting to {}->http://proxy.eclipse.org:9898->http://git.eclipse.org:80: No route to host (Host unreachable)
Dec 17, 2018 5:50:20 AM org.eclipse.ecf.provider.filetransfer.httpclient4.SNIAwareHttpClient tryConnect
INFO: Retrying connect to {}->http://proxy.eclipse.org:9898->http://git.eclipse.org:80
Mirroring http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/org.eclipse.setup
FAILED to load http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/org.eclipse.setup
  ERROR: org.eclipse.oomph.util.IOExceptionWithCause: No route to host (Host unreachable): http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/org.eclipse.setup 0 0 0
There were failures so no entries will be deleted from the archive
No updates for /home/data/httpd/download.eclipse.org/oomph/www/setups.zip
Re: Oomph Setups.zip outdated? [message #1799918 is a reply to message #1799910] Mon, 17 December 2018 13:22 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30452
Registered: July 2009
Senior Member
No, this seems very wrong! It's failing to load the root resource so its nothing related to your changes. The last update to setups.zip was December 12 so something started failing in terms of being able access gitc.clipse.org after that point in time. I will investigate and get back to you on this thread when it's working again.
Re: Oomph Setups.zip outdated? [message #1799919 is a reply to message #1799918] Mon, 17 December 2018 13:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30452
Registered: July 2009
Senior Member
I was able to run this locally on my machine, so it seems to be a proxy/server problem on the build server. I've opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=542852 to track the problem, so you may wish to monitor that bug for its resolution.
Re: Oomph Setups.zip outdated? [message #1799923 is a reply to message #1799919] Mon, 17 December 2018 14:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30452
Registered: July 2009
Senior Member
Our ultra responsive webmaster as fixed the problem and I've changed the job so that it no longer configures a proxy server so this shouldn't happen again. I've checked that the setups.zip is actually updated and that it contains your changed version of Scout.setup.
Re: Oomph Setups.zip outdated? [message #1799928 is a reply to message #1799923] Mon, 17 December 2018 14:57 Go to previous message
Patrick Bänziger is currently offline Patrick BänzigerFriend
Messages: 89
Registered: September 2011
Member
We've rerun our tests and it works without a hitch now!

Thank you for your quick response Ed! (And thanks to the webmaster, too!)
Previous Topic:Installed Eclipse Still referring to eclipse.org URL
Next Topic:Outline view blank when using Oomph setup editor
Goto Forum:
  


Current Time: Thu Sep 19 23:18:49 GMT 2019

Powered by FUDForum. Page generated in 0.01850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top