Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » PyQT: "no QT plugin platform could be initialised"(trying to create a standalone QGIS application using Eclipse and Python interpreter)
PyQT: "no QT plugin platform could be initialised" [message #1799707] Wed, 12 December 2018 18:26
d de backer is currently offline d de backerFriend
Messages: 1
Registered: December 2018
Junior Member
hello,

trying to create a very simple standalone QGIS application using Eclipse (version 2018-09) with python interpreter (python 3.7), PyQt5, QGIS 3.4 ("madera"), following the "python python programming cookbook": "creating a standalone application".
(this pdf (2015) is definitely for older versions of QGIS & python, so I cannot follow it literally).

When I "run" the project in Eclipse I have the following message, over and over again (whatever adaptations I make in path and python_path systems variables):
"python3: this application failed because no QT plugin platform could be initialised."
No solution found after 3-4 hours of searching on internet (to recent versions ?)

Please also notice I'm a newbie, no IT-guy at all, I barely know what a batfile is. ..
So most of the internet techdiscussions are kind of Chinese for me.
Your suggestions should be really step-by-step. Thanks very much.

[Updated on: Wed, 12 December 2018 22:11]

Report message to a moderator

Previous Topic:Unreadable entry fields in dialogs
Next Topic:Cannot connect to SQLServer from eclipse
Goto Forum:
  


Current Time: Sat Feb 22 11:39:25 GMT 2020

Powered by FUDForum. Page generated in 0.03043 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top