Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » stackoverflow didn't solve no projects are found to import problem
stackoverflow didn't solve no projects are found to import problem [message #1799386] Thu, 06 December 2018 03:18 Go to next message
nayema laboni is currently offline nayema laboniFriend
Messages: 1
Registered: December 2018
Junior Member
Hi
I have used eclipse 4.7 Java EE, then I had to do some web dev stuff, so I assumed I would have to change perspective, so I choose web from the list when you click other after clicking perspective. I also created a new project as a static web project.
when I tried to import a project that's been downloaded in downloads of my laptop, into an existing workspace I had the error "no projects are found to import problem". I tried everything i found online can someone please help me I am already feeling down so please keep your judgement to yourself though I have higher views of this forum since its directly under eclipse
Re: stackoverflow didn't solve no projects are found to import problem [message #1799388 is a reply to message #1799386] Thu, 06 December 2018 05:22 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30897
Registered: July 2009
Senior Member
Exactly which Import wizard did you use? "General-> Existing Projects into Workspace"? That wizard will only import "existing projects" and it will recognize a file system folder as an Eclipse project only if it contains a .project file, i.e., if it really was an Eclipse project exported or copied from some previous Eclipse workspace. The latest Eclipse version has Import... General -> Projects from Folder or Archive that will likely (I haven't used it) do a better job of looking at the folder contents to see if it can figure out what type of project the folder should be. Failing that, you should create a project (of the correct type using the appropriate project wizard) and use Import... -> General -> File System to import/copy file system contents into that project.
Re: stackoverflow didn't solve no projects are found to import problem [message #1799548 is a reply to message #1799388] Mon, 10 December 2018 04:44 Go to previous message
Patrick Moran is currently offline Patrick MoranFriend
Messages: 142
Registered: March 2018
Senior Member
It sounds like Ed Merks is probably right. I've been puzzled by this kind of problem before, and sometimes I've been very frustrated because I can't see into the structures that are implicit in the hidden files in a project.

If you are using a Macintosh, there are instructions that are easy to find via search engine on how to make the invisible files visible. If you are still having trouble after you try Ed's suggestions you could start by getting clear on how the workspace you have created differs from other workspaces that have been successful.

At one time I switched over to Photon from Oxygen, since I was changing to a new Mac, and I found that to get access to projects from my previous work it was not enough to copy just a project into the new computer. I had to start by creating a new project in Oxygen in a new workspace. That resulted in a sort of prototypical workspace being present on the new computer. Evidently it contains files that succeeding workspaces must use because it did not work to simply copy an old workspace from the old computer to the new computer, open that workspace in Photon (which showed up empty in the open Photon window), and then import files by the usual method, i.e., import existing projects. When I had made a new workspace and a new project from scratch in Photon, demonstrated that the new project could be run, etc., and then copied a workspace from the old computer into the same directory the new workspace on the new computer was in, I could then use Eclipse to open the older workspace and subsequently import the old projects. That seemed to work for me, but I eventually had enough problems with the convoluted steps needed to make a third workspace, and in carrying my new work forward, that I deleted Photon and went back to Oxygen.

For me, that solution did not work out well either. I also did not want to get stuck with a project that I could not revise at some time in the future when there have been several generations more of Eclipse.

At the same time, I wanted to completely revise my GUI with the hope that I could make it shrink to fit smaller screen, and attempts to do that with an existing project resulted in situations where the code for a button or whatever became detached (in those invisible files I suppose) from the GUI button on screen. So in the end I had to begin all over again, make the new GUI, and then rather laboriously copy and revise code for all the various components. I did not keep a running account of what I was doing, so I may have forgotten to include some of my blunders.

I think it may help to get things started by making a new user space for use with your current Eclipse, then make a simple "hello world" or whatever, and be sure that you can get that done without any major hitches. Then you could try to copy the old workspace with a new name into the same directory with the new user space you just made, and perhaps you will be able to change to that renamed userspace, and then do an "import-as-project" the old projects from your previous setup. If that doesn't work you may need to rebuild by taking a minimal GUI produced by WindowMaker, reproducing the on-screen GUI elements, and then "port" by copying segment by segment the code that you had earlier written. I suggest importing a bit and then running the revised code to be sure that you don't miscopy something that will stand as a hidden error in the midst of what would be ten or twenty pages of code from your original Xyzxyz.jave file as it would be if printed out. If you make an error and Eclipse doesn't flag it, it can be hard to find if you have too much code to check over.

I hope Ed's suggestions work for you and that you won't have to go through all this mish-mash of steps.
Previous Topic:jdk11 is not supported in eclipse4.9
Next Topic:SOLVED JavaFX event bubbling bug in Eclipse Oxygen?
Goto Forum:
  


Current Time: Sun Feb 23 21:00:11 GMT 2020

Powered by FUDForum. Page generated in 0.04626 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top