Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » Splash screen issues for AUT
Splash screen issues for AUT [message #1797903] Thu, 08 November 2018 10:43
Gizem Erguder is currently offline Gizem ErguderFriend
Messages: 2
Registered: November 2018
Junior Member
Hi,

My UAT has a splash screen where user enters his login credentials. The case is;
1) For a fresh start user has to delete a file where his previously entered credentials are stored (for which i have a script of delete-file)
2) Then opens up the UAT to enter fresh login credentials through splash.

The thing with the scripts are:
1) delete-file opens up UAT splash when i run the script.
2) So i add a close UAT script as a second case with a perspective workbench context. It closes the UAT
3) I run the next script to login credentials. When i run these 3 scripts as separate cases; they work. (with following error in close UAT script but it still closes)
But when i put them into a suite; it gives following error. This error is the same with all splash screen cases. I always have to close them manually or it doesn't work.

Thanks,

Report:
Test case *Close AUT* time: 0.919 s
Result: CANCEL, message: Context execution is terminated
--------------Logs BEGIN-------------------
Initial log:
!ENTRY org.eclipse.rcptt.runtime.ui 1 0 2018-11-08 13:21:49.962
!MESSAGE Workbench is about to shut down
!STACK 0
java.lang.Exception: Just to get a current stack trace logged. This is not an error.
at org.eclipse.rcptt.internal.runtime.ui.Q7RuntimeStartup$1.preShutdown(Q7RuntimeStartup.java:33)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:989)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:173)
at org.eclipse.ui.internal.Workbench.firePreShutdown(Workbench.java:986)
at org.eclipse.ui.internal.Workbench.busyClose(Workbench.java:1125)
at org.eclipse.ui.internal.Workbench.access$22(Workbench.java:1113)
at org.eclipse.ui.internal.Workbench$19.run(Workbench.java:1454)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.Workbench.close(Workbench.java:1451)
at org.eclipse.ui.internal.Workbench.close(Workbench.java:1424)
at org.eclipse.swt.widgets.RunnableLock.run_aroundBody0(RunnableLock.java:35)
at org.eclipse.swt.widgets.RunnableLock$AjcClosure1.run(RunnableLock.java:1)
at org.eclipse.rcptt.tesla.swt.aspects.DisplayAspect.ajc$around$org_eclipse_rcptt_tesla_swt_aspects_DisplayAspect$10$90b1ba39proceed(DisplayAspect.aj:345)
at org.eclipse.rcptt.tesla.swt.aspects.DisplayAspect.ajc$around$org_eclipse_rcptt_tesla_swt_aspects_DisplayAspect$10$90b1ba39(DisplayAspect.aj:367)
at org.eclipse.swt.widgets.RunnableLock.run_aroundBody2(RunnableLock.java:35)
at org.eclipse.swt.widgets.RunnableLock$AjcClosure3.run(RunnableLock.java:1)
at org.eclipse.rcptt.sherlock.aspects.swt.DisplayAspect.ajc$around$org_eclipse_rcptt_sherlock_aspects_swt_DisplayAspect$2$90b1ba39proceed(DisplayAspect.aj:41)
at org.eclipse.rcptt.sherlock.aspects.swt.DisplayAspect.ajc$around$org_eclipse_rcptt_sherlock_aspects_swt_DisplayAspect$2$90b1ba39(DisplayAspect.aj:63)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4024)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3700)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1127)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1018)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:694)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:606)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
at org.eclipse.equinox.launcher.Main.run(Main.java:1515)
at org.eclipse.equinox.launcher.Main.main(Main.java:1488)
!ENTRY unknown 8 1 2018-11-08 13:21:50.796
!MESSAGE
--------------Logs END-------------------

Total wait time:
There were no third-party methods RCPTT was waiting for

[Updated on: Mon, 26 November 2018 14:10]

Report message to a moderator

Previous Topic:How to add Environment variable for AUT
Next Topic:problem with nebula-grid
Goto Forum:
  


Current Time: Wed Feb 21 16:42:47 GMT 2024

Powered by FUDForum. Page generated in 0.01898 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top