Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Windows 10 Exit 1 error(Eclipse returns exit 1 error, JDK and JRE compatable and downloaded)
Windows 10 Exit 1 error [message #1795839] Sun, 30 September 2018 23:53 Go to next message
Scott Slessor is currently offline Scott SlessorFriend
Messages: 3
Registered: September 2018
Junior Member
I am recieving a exit 1 error when I try to launch Eclipse, it says I do not have a JDK/JRE in a location that does not even exist on my computer. I do have a JDK and JRE downloaded however I cannot seem to point Eclipse to them, I've tried a -vm and I get the same error, nothing seems to be working that I could find. Running all of this on Windows 10.
Re: Windows 10 Exit 1 error [message #1795841 is a reply to message #1795839] Mon, 01 October 2018 00:21 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3276
Registered: July 2009
Senior Member

What are the contents of your eclipse.ini file? Have you modified it in any way?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Windows 10 Exit 1 error [message #1795842 is a reply to message #1795841] Mon, 01 October 2018 00:33 Go to previous messageGo to next message
Scott Slessor is currently offline Scott SlessorFriend
Messages: 3
Registered: September 2018
Junior Member
-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar

--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834
-product
org.eclipse.epp.package.java.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
--add-modules=ALL-SYSTEM
-vm
K:\Java\jdk1.8.0_171\bin\javaw.exe

That's my current eclipse.ini and I added the -vm <location of my jdk> part

[Updated on: Mon, 01 October 2018 00:43]

Report message to a moderator

Re: Windows 10 Exit 1 error [message #1795844 is a reply to message #1795842] Mon, 01 October 2018 01:40 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3276
Registered: July 2009
Senior Member

You can't have anything that's not a valid argument for the JVM after the -vmargs
line, including the -vm switch and location. Move them above the -vmargs line. -1 is
most often reported on invalid arguments.


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 01 October 2018 01:41]

Report message to a moderator

Re: Windows 10 Exit 1 error [message #1795845 is a reply to message #1795844] Mon, 01 October 2018 01:44 Go to previous messageGo to next message
Scott Slessor is currently offline Scott SlessorFriend
Messages: 3
Registered: September 2018
Junior Member
-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar

--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834
-product
org.eclipse.epp.package.java.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile-vm
K:\Java\jdk1.8.0_171\bin\javaw.exe
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
--add-modules=ALL-SYSTEM

Moved it, Now it says it cannot find it's companion Jar

[Updated on: Mon, 01 October 2018 01:51]

Report message to a moderator

Re: Windows 10 Exit 1 error [message #1795873 is a reply to message #1795845] Mon, 01 October 2018 15:05 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3276
Registered: July 2009
Senior Member

The way you have "openFile-vm" on a single line still looks a little weird. The companion jar message
can be related to file permissions--you need both read and execute permissions on any .dll files.


Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Eclipse 4.9 is full of micro-freezes
Next Topic:Eclipse won't start
Goto Forum:
  


Current Time: Thu Oct 18 02:36:18 GMT 2018

Powered by FUDForum. Page generated in 0.03679 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top