Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error running app on MacOS
Error running app on MacOS [message #1795512] Mon, 24 September 2018 14:53 Go to next message
Dom Cassone is currently offline Dom CassoneFriend
Messages: 5
Registered: August 2013
Junior Member
I am trying to install the SimRel version of Eclipse. I downloaded the app, decompressed it but when I tried to run it I got:
Failed to find a Main Class in "/private/var/folders/tc/41y795px1_bggyx2kwwl6l940000gn/T/AppTranslocation/DE2735A0-DBFC-44D9-BEF8-8DE698B99E40/d/Eclipse Installer 2.app/Contents/MacOS//../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar".

I am running MacOS High Sierra (12.13.6)

Any ideas would be appreciated...thanks!

Dom
Re: Error running app on MacOS [message #1795522 is a reply to message #1795512] Mon, 24 September 2018 16:29 Go to previous messageGo to next message
Dom Cassone is currently offline Dom CassoneFriend
Messages: 5
Registered: August 2013
Junior Member
I get a similar error with Photon:
Failed to find a Main Class in "/Volumes/Eclipse/Eclipse.app/Contents/MacOS//../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar".
Re: Error running app on MacOS [message #1795542 is a reply to message #1795522] Tue, 25 September 2018 03:22 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29598
Registered: July 2009
Senior Member
Could you trying the following version of the installer and report back whether that version works for you?

http://www.eclipse.org/downloads/download.php?file=/oomph/products/latest/eclipse-inst-mac64.tar.gz
Re: Error running app on MacOS [message #1795923 is a reply to message #1795542] Tue, 02 October 2018 13:11 Go to previous messageGo to next message
Robert Poor is currently offline Robert PoorFriend
Messages: 1
Registered: October 2018
Junior Member
I'm also unable to launch Eclipse-inst on Mojave (MacOS 10.14 (18A391)) using eclipse-inst-mac64.tar.gz. The unzipped app Eclipse Installer gets a SIGSEGV almost immediately.

I'll file a bug report with more info.
Re: Error running app on MacOS [message #1796086 is a reply to message #1795923] Fri, 05 October 2018 02:30 Go to previous messageGo to next message
Dwight Read is currently offline Dwight ReadFriend
Messages: 4
Registered: October 2018
Junior Member
I also get the error "Failed to find a Main Class in '/private/var/folders/.../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar'' "when I download Eclipse SimRel and use the Eclipse Installer. Any suggestions?
Re: Error running app on MacOS [message #1796091 is a reply to message #1796086] Fri, 05 October 2018 03:46 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3277
Registered: July 2009
Senior Member

Where did you unpack it?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Error running app on MacOS [message #1796098 is a reply to message #1796091] Fri, 05 October 2018 06:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29598
Registered: July 2009
Senior Member
Did you try my earlier suggestion? As of yet, no one has responded with "yes I tried that and it does/doesn't work".

Unfortunately I can't try it because I don't have a Mac and my Mac virtual box is an old version on which the latest version of Eclipse (and therefore the Installer) doesn't run at all because the right system libraries are not available.
Re: Error running app on MacOS [message #1796132 is a reply to message #1796091] Fri, 05 October 2018 17:53 Go to previous messageGo to next message
Dwight Read is currently offline Dwight ReadFriend
Messages: 4
Registered: October 2018
Junior Member
I unpacked it in Applications and ran Eclipse Installer from Applications.
Re: Error running app on MacOS [message #1796133 is a reply to message #1796098] Fri, 05 October 2018 17:55 Go to previous messageGo to next message
Dwight Read is currently offline Dwight ReadFriend
Messages: 4
Registered: October 2018
Junior Member
Ed Marks: I tried your suggestion and got the message essentially saying that this is an older version that won't run on my Mac (Sierra 10.13.6). What I just wrote is not correct. The message was: "Version 1.6.0_65 of the JVM is not suitable for this product Version 1.8 or greater is required."

[Updated on: Fri, 05 October 2018 18:02]

Report message to a moderator

Re: Error running app on MacOS [message #1796145 is a reply to message #1796133] Sat, 06 October 2018 06:18 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29598
Registered: July 2009
Senior Member
Thanks for the reply!

You must install a 1.8 or higher JDK on your system.

https://wiki.eclipse.org/Eclipse/Installation
Re: Error running app on MacOS [message #1796148 is a reply to message #1796145] Sat, 06 October 2018 08:38 Go to previous message
Dwight Read is currently offline Dwight ReadFriend
Messages: 4
Registered: October 2018
Junior Member
When I read the message, I thought that that was the case. I installed JDK 1.8 and then I was able to install Eclipse.
Previous Topic:Arabic Font In Export to PDF on Linux
Next Topic:Getting an error in Mac OS
Goto Forum:
  


Current Time: Sat Oct 20 08:36:39 GMT 2018

Powered by FUDForum. Page generated in 0.04102 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top