Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Do i need to download a compiler? (Using Eclipse on Mac)
Do i need to download a compiler? [message #1795281] Wed, 19 September 2018 19:56 Go to next message
Luse  Levi is currently offline Luse LeviFriend
Messages: 1
Registered: September 2018
Junior Member
Hi Guys,

I'm new to coding, and just trying to find some help or if someone can shine some light on a situation for me.

I'm looking for an IDE that i can work with on Mac that will let me Code in C++ as well as let me compile, and run my code. i know that Eclipse works on Mac, But after I download and install eclipse will i need to download a compiler from elsewhere? or does eclipse have the compiler built in? if i need to get it elsewhere how do i get it and how do i install it?

Also will i be able to run my codes through Eclipse for Mac?

I know these are stupid question but i could not find any answers online. Thank You.
Re: Do i need to download a compiler? [message #1795296 is a reply to message #1795281] Thu, 20 September 2018 04:48 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29593
Registered: July 2009
Senior Member
A quick hunt from https://www.eclipse.org/cdt/ for getting started information and looking at https://www.codeproject.com/Articles/14222/C-Development-using-eclipse-IDE-Starters-guide suggests the following:
Quote:

For running CDT from eclipse, you need to have the following tools.

Make tools for make process.
GNU compiler collection (GCC) for compilations.
GDB for debugging.

You can download all these tools from www.MinGW.org. You have to download and install build tools (make), compiler (GCC) and debugger (GDB). You can find all these tools in the location www.cygwin.com also. But I recommend the usage of mingw.

CDT's support page https://www.eclipse.org/cdt/support.php also suggests using their more specific forum for asking CDT questions.
Previous Topic:How do i verify if tomcat v9.0 is vulnerable to slowloris vulnerability?
Next Topic:Apply filters on data of BIRT reports
Goto Forum:
  


Current Time: Thu Oct 18 03:56:14 GMT 2018

Powered by FUDForum. Page generated in 0.03151 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top