Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Error installing Papyrus on Ubuntu
Error installing Papyrus on Ubuntu [message #1795049] Thu, 13 September 2018 14:21 Go to next message
Twan Dieltjes is currently offline Twan DieltjesFriend
Messages: 22
Registered: September 2018
Junior Member
I want to use Papyrus RT on Ubuntu for college.
I've installed Java JRE and build-essentials
Downloaded the All-One RCP package.
Unpacked it at my homedrive.
At the first launch, it created the workspace folder and then it stopped with an error to look into the .metadata/.log file


I've attached the logfile.
Does this sound as a known issue?

  • Attachment: error.log
    (Size: 5.90KB, Downloaded 62 times)
Re: Error installing Papyrus on Ubuntu [message #1795087 is a reply to message #1795049] Fri, 14 September 2018 09:08 Go to previous messageGo to next message
Patrick Tessier is currently offline Patrick TessierFriend
Messages: 252
Registered: July 2009
Location: Paris Saclay, France
Senior Member
Hi,

It seems that you have not the good JRE (there is no javax) because I see in your log : Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418

Another post have dicussed baout this problem: https://www.eclipse.org/forums/index.php/t/1090046/ may be it can help you.
Best Regard,
Patrick
Re: Error installing Papyrus on Ubuntu [message #1795088 is a reply to message #1795087] Fri, 14 September 2018 09:29 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6848
Registered: July 2009
Senior Member
Hi

The instability of Java is causing considerable trouble for Eclipse.

Java 9 introduced modules and so broke the simple classpath concept so that some packages are not found by legacy code. The referenced message demonstrates the bad things that happen when you use Java 9+ on a version of Eclipse that lacks the relevant adaptations.

The location of javax.annotation seems to change in Java 10 and be removed in Java 11 again causing breakages that are currently the topic of https://bugs.eclipse.org/bugs/show_bug.cgi?id=539038 for Eclipse 2018-12.

Eclipse 2018-09 has a last minute workaround to avoid a Tycho breakage: https://bugs.eclipse.org/bugs/show_bug.cgi?id=538564

"eclipse.buildId=unknown" suggests that you are using a development version of Eclipse that might not have the Bug 538564 fix.

If you have a reproducible problem on an official release, please raise/contribute to a Bugzilla.

If you really want to use Java 9+ make sure you use the latest Eclipse. Much the simplest solution is to use Java 8.

Regards

Ed Willink
Re: Error installing Papyrus on Ubuntu [message #1795407 is a reply to message #1795088] Fri, 21 September 2018 12:03 Go to previous message
Twan Dieltjes is currently offline Twan DieltjesFriend
Messages: 22
Registered: September 2018
Junior Member
Thanks, the issue is fixed by installingen Java 8.
I overlooked that.

Previous Topic:Bug in Sequence Diagram
Next Topic:New to papyrus. Expanding the pingpong tutorial
Goto Forum:
  


Current Time: Sun Sep 27 16:41:17 GMT 2020

Powered by FUDForum. Page generated in 0.02336 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top