Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error while launching eclipse, can't launche eclipse
Error while launching eclipse, can't launche eclipse [message #1794929] Tue, 11 September 2018 08:57 Go to next message
Hugoa Maitre is currently offline Hugoa MaitreFriend
Messages: 1
Registered: September 2018
Junior Member
Hi,

I have a fresh Linux mint 19 install.
I installed openjdk8 and eclipse.

I get this error .

An error has occurred. See the log file
/home/masterh/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1536655935704.log

The log file contains this error:

1 !SESSION Tue Sep 11 10:54:53 CEST 2018 -----------------------------------------
2 !ENTRY org.eclipse.equinox.launcher 4 0 2018-09-11 10:54:53.283
3 !MESSAGE Exception launching the Eclipse Platform:
4 !STACK
5 java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
6 at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
7 at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
8 at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
9 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
10 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
11 at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
12 at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

I don't know what to do. I tried to install the java jdk from oracle. I even tried to install Netbeans, it is not working either, another error message.

Thank you.
Re: Error while launching eclipse, can't launche eclipse [message #1794954 is a reply to message #1794929] Tue, 11 September 2018 14:57 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3296
Registered: July 2009
Senior Member

Have you tried it with a copy of eclipse downloaded from download.eclipse.org? The (what looks like) 3.8 version there looks ancient.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Eclipse rcp migration from eclipse 3.7 to eclipse 5
Next Topic:Javaw issue
Goto Forum:
  


Current Time: Tue Nov 13 07:12:22 GMT 2018

Powered by FUDForum. Page generated in 0.03154 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top