Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Changing VM Arguments field doesn't offer to save run configuration
Changing VM Arguments field doesn't offer to save run configuration [message #1794385] Thu, 30 August 2018 00:10 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 581
Registered: July 2009
Senior Member
Using v4.8.0.

I'm seeing a problem with run configurations in Photon that I've never seen before.

I often need to enter property settings in the "VM arguments" field in the run configuration and save those changes permanently.

Today, I'm seeing that when I enter text in that field, the "Apply" button doesn't ungrey.

I also tested making a change to the "Program arguments" field, and it does the same thing.

However, I was able to figure out a workaround. I found that the "Working directory" field does not have this problem. I tried changing it to "Other" and then entering the same value as the default. That made the Apply button sensitive. I then went up to the "VM arguments" field and entered the text I needed to add.

I then clicked Apply. When I ran my test, I verified that it was working, which means it was reading those additional properties I set. This also demonstrates that not only was it not letting me apply the changes earlier, it actually wasn't even using them at all, because if I just clicked "Run", my test fails because those required properties are not set. I guess this last point is not that surprising.
Re: Changing VM Arguments field doesn't offer to save run configuration [message #1794386 is a reply to message #1794385] Thu, 30 August 2018 04:13 Go to previous message
Sarika Sinha is currently offline Sarika SinhaFriend
Messages: 81
Registered: February 2010
Location: Bangalore, India
Member
Please create a bug with the steps / Projects as I am not able to reproduce this problem.
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=JDT


Sarika Sinha
JDT Programmer
Previous Topic:How to detect initialization order of fields?
Next Topic:Windows Builder not working?
Goto Forum:
  


Current Time: Mon Nov 19 23:55:37 GMT 2018

Powered by FUDForum. Page generated in 0.02017 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top