Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Need to remove dependency on WSDL4J 1.5.1 plugin(Need to remove dependency on WSDL4J 1.5.1 plugin)
Need to remove dependency on WSDL4J 1.5.1 plugin [message #1794159] Fri, 24 August 2018 15:54
David Brock is currently offline David BrockFriend
Messages: 6
Registered: February 2014
Junior Member
My company will not allow me to distribute BIRT to customers as a solution with WSDL4J 1.5.1 included because CPL 1.0 license terms are disfavored.

I tried removing the WSLD4J plugin and the WS ODA plugins. However, the report viewer plugins also have a dependency on WSDL4J through bundle dependency on AXIS.

Is there any way that I could modify/rebuild/replace the AXIS plugin so that it has an optional dependency on WSDL4J, assuming that it is not required for the report viewer functionality?

Thanks,
David

[Updated on: Fri, 24 August 2018 16:10]

Report message to a moderator

Previous Topic:Page break after master page/orientation change
Next Topic:ClassNotFoundException: org.eclipse.jetty.jndi.InitialContextFactory in report preview
Goto Forum:
  


Current Time: Tue Nov 20 00:29:56 GMT 2018

Powered by FUDForum. Page generated in 0.02093 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top