Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot find JVM required for new installation.(Trying to upgrade to latest Eclipse but "Version 1.6.9_65 of the JVM" is not suitable)
Cannot find JVM required for new installation. [message #1793886] Sat, 18 August 2018 22:28 Go to next message
Patrick Moran is currently offline Patrick MoranFriend
Messages: 62
Registered: March 2018
Member
I'm trying to upgrade to latest Eclipse but fail. with: "Version 1.6.9_65 of the JVM" is not suitable
The full error message I get is:
- Version 1.6.9_65 of the JVM is not suitable for this. product.
Version 1.8 or greater is required.

I've searched the Oracle site and they have a jvm.dll but nothing else seems relevant. I've installed the Eclipse-suggested version of Java, and also the very newest version, I even restarted, but get the same error message.

I'm using Mac OS 10.13.6 , which is fine with Oxygen.

Why do I get the same error regardless of what version of Java is installed? And what is a JVM? I've Googled JVM and just get a few random mentions.

[Updated on: Sat, 18 August 2018 22:31]

Report message to a moderator

Re: Cannot find JVM required for new installation. [message #1793889 is a reply to message #1793886] Sun, 19 August 2018 04:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29552
Registered: July 2009
Senior Member
The Mac has some idiosyncrasies. The OS will generally give wrong feedback about the required JVM, often telling you that you need an older one when you might already have a newer JRE installed. Did you read the following?

https://wiki.eclipse.org/Eclipse/Installation

There it says:

If you're using Mac, and you don't have a JDK installed, you may get a bogus message from the OS stating that you should "install the legacy Java SE 6 runtime". Installing that will not solve the problem, because recent versions of Eclipse require a higher version. If you install just a JRE, and not a full JDK, that error message will persist. You must install a full JDK.

So on the Mac you must install a JDK. It must be at least 1.8 for any recent version of Eclipse. The installer will try to find a suitable JDK. It uses the following command to find them all, i.e., it parses the XML emitted by the following:

/usr/libexec/java_home -X

A JVM is a Java Virtual Machine. A JRE is a Java Runtime Environment and a JDK is a Java Development Toolkit. Both a JRE and a JDK contain a JVM (the Java executable that you run which can emulate/executate the .class file byte code), along with the Java class libraries they need, but a JDK contains more tools and includes a JRE. I have no idea why a full JDK is required on the Mac, but it is.
Re: Cannot find JVM required for new installation. [message #1793901 is a reply to message #1793889] Mon, 20 August 2018 01:34 Go to previous message
Patrick Moran is currently offline Patrick MoranFriend
Messages: 62
Registered: March 2018
Member
Thank you.
I'll give it a try when I boot my newer computer up. I thought I got the latest of everything, but I guess I failed.
Previous Topic:Eclipse version 3 plugins
Next Topic:PUBLIC MQTT BROKER WITH SSL/TLS
Goto Forum:
  


Current Time: Tue Sep 25 19:07:41 GMT 2018

Powered by FUDForum. Page generated in 0.05772 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top