Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » "It" says there are JET warnings but doesn't display them!
"It" says there are JET warnings but doesn't display them! [message #1793788] Wed, 15 August 2018 20:45 Go to next message
Bill Sherman is currently offline Bill ShermanFriend
Messages: 8
Registered: April 2018
Junior Member
I'm using an old version of Java (it's what the previous developer used) to work with EMF and JET.

Java command line in Ant build:

[java] Executing 'C:\Program Files\RedHat\java-1.8.0-openjdk-1.8.0.171-1\jre\bin\java.exe' with arguments:
'-classpath'
'C:\eclipse44\plugins;C:\eclipse44\plugins\org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar'
'org.eclipse.core.launcher.Main'
'-clean'
'-noupdate'
'-data'
'C:\Bill\BBBY-development\Eclipse\siuser\bc\stubs\temp\posbc_ws2'
'-application'
'org.eclipse.emf.codegen.ecore.Generator'
'C:\Bill\BBBY-development\Eclipse\siuser\bc\stubs\siibmPOSBC.genmodel'

Along with the usual message about the bundle being activated before the state location was initialized:

[java] org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized. Will retry after the state location is initialized.
[java] >>> Generating C:\Bill\BBBY-development\Eclipse\siuser\bc\stubs\siibmPOSBC.genmodel
[java] org.eclipse.m2e.logback.configuration: Logback config file: C:\Bill\BBBY-development\Eclipse\siuser\bc\stubs\temp\posbc_ws2\.metadata\.plugins\org.eclipse.m2e.logback.configuration\logback.1.5.1.20150109-1820.xml
[java] org.eclipse.m2e.logback.configuration: Initializing logback
[java] >> Examining project 'posbc'
[java] >> Refreshing '/posbc'.
[java] >> Opening 'posbc'.
[java] >> Refreshing '/posbc'.
[java] >> Generating code
[java] >> Generating packages

I'm also seeing an indication that there are warnings:

[java] >> Create target file
[java] >> JET creating '/.JETEmitters/src/org/eclipse/emf/codegen/ecore/templates/model/PackageClass_.java'
[java] >> JET building '.JETEmitters'
[java] >> Invoking 'Java Builder' on '/.JETEmitters'.
[java] >> Reading resource change information for .JETEmitters
[java] >> Preparing to build .JETEmitters
[java] >> Analyzing deltas
[java] >> Analyzing sources
[java] >> Compiling .JETEmitters/src/org/eclipse/emf/codegen/ecore/templates/model
[java] >> (Found 44 warnings) Compiling .JETEmitters/src/org/eclipse/emf/codegen/ecore/templates/model
[java] >> (Found 44 warnings) Build done
[java] >> JET loading class 'PackageClass_.class'

in my Ant log file. I have no idea where to view the details of these 44 warnings.

I use this to start the Ant logging:

<record name="${basedir}/build.log" loglevel="verbose" action="start"/>

Thanks,
Bill
Re: "It" says there are JET warnings but doesn't display them! [message #1793800 is a reply to message #1793788] Thu, 16 August 2018 04:42 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6407
Registered: July 2009
Senior Member
Hi Bill,

it seems you're using dynamic templates. The JET compiler compiles them to Java source code in the project ".JETEmitters", which may be invisible in your Package Explorer because of the leading "." (dot) in the project name. Can you see the project and the problem markers when you disable the filter ".* resources" in the Package Explorer?

Cheers
/Eike
Previous Topic:EMF simple example
Next Topic:"It" says there are JET warnings but doesn't display them!
Goto Forum:
  


Current Time: Wed Nov 14 09:33:58 GMT 2018

Powered by FUDForum. Page generated in 0.01571 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top