Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Plugin in P2 Task requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' (AnyEditTools with Oxygen requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' )
Plugin in P2 Task requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' [message #1793455] Wed, 08 August 2018 16:15 Go to next message
Michael Müller is currently offline Michael MüllerFriend
Messages: 4
Registered: December 2017
Junior Member
Hello,
I have a setup, which i will use to prepare a Eclipse Version that contains several different Plugins.
Now I have trouble with the Plugin AnyEditTools. If I use Photon as Product Version all is working fine. If I use Oxygen i got the error message
  ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
    ERROR: org.eclipse.equinox.p2.director code=0 Software currently installed: AnyEdit Tools 2.7.1.201709201439 (de.loskutov.anyedit.AnyEditTools 2.7.1.201709201439)
    ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: AnyEdit Tools 2.7.1.201709201439 (de.loskutov.anyedit.AnyEditTools 2.7.1.201709201439) requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' but it could not be found
  OK: unknown code=0 OK


If I remove the plugin from the setup and install the plugin manually in the prepared Oxygen Eclipse all is fine.
My Setup file looks very simple (attached File)

Any idea what could be wrong?
Re: Plugin in P2 Task requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' [message #1793461 is a reply to message #1793455] Wed, 08 August 2018 17:07 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
The problem is that in Photon they made changes to p2 to generate more requirements. Specifically all the BREE declarations in each MANIFEST.MF now generate an additional requirement, i.e., exactly like the one you see failing. But in Oxygen those requirements aren't available. An actual Oxygen installation doesn't recognize these new requirements so ignores them, so you'll be able to install manually. But I thought published installer was based on Oxygen. Which installer fails in this way?
Re: Plugin in P2 Task requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=1.7))' [message #1793487 is a reply to message #1793461] Thu, 09 August 2018 06:23 Go to previous message
Michael Müller is currently offline Michael MüllerFriend
Messages: 4
Registered: December 2017
Junior Member
The attached installer failed on Oxygen but works with Photon. I have also many other installers where the same plugin is used. And these installers also don't work now. Some times before, the installers are working well also with Oxygen. Now (i don't know exactly the time) i get all the time the same error. AnyEditTool plugin is same version like before.
I have no idea why it suddenly stops working.
Previous Topic:eclipseintaller
Next Topic:Upgrading Oomph on Ubuntu 18.04
Goto Forum:
  


Current Time: Sun Nov 18 06:17:52 GMT 2018

Powered by FUDForum. Page generated in 0.02104 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top