Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Perf Error(Perf throws an error an does not show results)
Perf Error [message #1793390] Tue, 07 August 2018 11:10 Go to next message
Tom Koller is currently offline Tom KollerFriend
Messages: 3
Registered: August 2018
Junior Member
Hey guys,

i installed the perf profiling tool via The addon center of eclipse photon.

i also installed linux-tools to make the perf command available.

when running profiling tools timing i encounter a strange error:

[ perf record: Woken up 6 times to write data ]
[ perf record: Captured and wrote 1.957 MB perf.data (50648 samples) ]
/usr/bin/perf record --output=perf.data /home/tomlucas/eclipse-workspace/zavi/ODE tryouts/Debug/ODE tryouts
Analysing recorded perf.data, please wait...
ERROR: Unable to find Perf version, please verify it is installed and on the run path


the perf record command works and i can use perf report on the written data but eclipse fails to show me the results.

Does anyone has a workaround for this ?

Cheers
Re: Perf Error [message #1796479 is a reply to message #1793390] Sun, 14 October 2018 22:50 Go to previous messageGo to next message
Jacques Schmitz Junior is currently offline Jacques Schmitz JuniorFriend
Messages: 1
Registered: October 2018
Junior Member
Hi there,

Did you find any solution for this yet? I am having the same problem.

Thanks,
Re: Perf Error [message #1796513 is a reply to message #1796479] Mon, 15 October 2018 15:11 Go to previous messageGo to next message
David VavraFriend
Messages: 803
Registered: October 2012
Senior Member
I presume you are using EPIC the Eclipse Perl Integration
This forum is for Eclipse CDT

You might get an answer here but you should try the EPIC forum at SourceForge
https://sourceforge.net/p/e-p-i-c/discussion/
Re: Perf Error [message #1796561 is a reply to message #1796513] Tue, 16 October 2018 06:36 Go to previous message
Tom Koller is currently offline Tom KollerFriend
Messages: 3
Registered: August 2018
Junior Member
@Schmitz Junior
Quote:

Did you find any solution for this yet? I am having the same problem.

I have not found a workaraound for the Perf tool since i wasnt able to get any better information about it.
Instead i wrote my own profiler which works now so i wont try any further.

@David Vavra
Quote:
I presume you are using EPIC the Eclipse Perl Integration
This forum is for Eclipse CDT


I am quite sure i am using eclipse-cdt but i missed to give my IDE Version Info
Eclipse IDE for C/C++ Developers

Version: Photon Release (4.8.0)
Build id: 20180619-1200

Regards

[Updated on: Tue, 16 October 2018 06:37]

Report message to a moderator

Previous Topic:first opening for Eclipse IDE C++: errors
Next Topic:Whats the state of CMake Build Support ?
Goto Forum:
  


Current Time: Mon Nov 12 17:46:43 GMT 2018

Powered by FUDForum. Page generated in 0.01964 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top