Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Element edges are not deleting from container
Element edges are not deleting from container [message #1792997] Fri, 27 July 2018 09:24 Go to next message
Pratiksha Dalal is currently offline Pratiksha DalalFriend
Messages: 19
Registered: May 2018
Junior Member
Hi Community!

I am facing some problem in deleting element edges
When i connect two nodes it is connecting properly but when i delete one of the node then edge gets deleted but only visually not from the container in my .model file it remains how can I delete the edges from container when one of the node is deleted

Any help would be appreciated
Thanks
Pratiksha
Re: Element edges are not deleting from container [message #1793208 is a reply to message #1792997] Wed, 01 August 2018 14:04 Go to previous message
Laurent Fasani is currently offline Laurent FasaniFriend
Messages: 133
Registered: October 2014
Senior Member
Hello

The edge will be removed only if the semantic element it relies on is deleted too.
To customize the deletion, you can create a deletion tool to override the default sirius behavior.
You can do then whatever operation in your delete tool including deleting semantic object or unseting a feature

Regards


Laurent Fasani - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Previous Topic:Cannot create a new container
Next Topic:Eclipse Oxygen with Sirius 6 and XText 2.14 - correct install?
Goto Forum:
  


Current Time: Thu Sep 20 16:59:38 GMT 2018

Powered by FUDForum. Page generated in 0.02051 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top