Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Unable to determine gdb-multiarch version(debugging with gdb-multiarch)
Unable to determine gdb-multiarch version [message #1792972] Thu, 26 July 2018 16:36 Go to next message
Elliot Swain is currently offline Elliot SwainFriend
Messages: 1
Registered: July 2018
Junior Member
I have been setting up eclipse photon to cross compile and debug code for my beaglebone black wireless. I have my arm-linux-gnueabihf toolchain working and compiling code, and I can use the remote system explorer to compile transfer and execute the code on the beablebone. I have yet to get it to debug though. I have just been trying to debug a simple hello world program. Everything seems to work until eclipse calls for the gdb-multiarch version on the host. I have gdb-multiarch installed on my host (linux ubuntu 18.04) and gdbserver installed on the target (beaglebone). The debug settings seem to be correct as far as I can tell. I have the path to the gdb-multiarch and I have tried using an init file (with set architecture to arm) and without. The error message that I get is Could not determine GDB version using command: /usr/bin/gdb-multiarch --version. It seems to be an issue on the host side.

When I type gdb-multiarch --version in the terminal I get this..

GNU gdb (Ubuntu 8.1-0ubuntu3) 8.1.0.20180409-git
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <omitted link>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<omitted link>
Find the GDB manual and other documentation resources online at:
<omitted link>
For help, type "help".
Type "apropos word" to search for commands related to "word".

I have searched google and read as many relative threads with somewhat similar issues, but havent been able to ascertain a resolution for myself. Any help or suggestions would be great.
Re: Unable to determine gdb-multiarch version [message #1793086 is a reply to message #1792972] Tue, 31 July 2018 01:12 Go to previous message
David VavraFriend
Messages: 805
Registered: October 2012
Senior Member
(* deleted *)

[Updated on: Tue, 31 July 2018 01:22]

Report message to a moderator

Previous Topic:How To Save Build Configuration
Next Topic:Arduino Library Management With Symlinks
Goto Forum:
  


Current Time: Fri Nov 16 11:21:59 GMT 2018

Powered by FUDForum. Page generated in 0.01450 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top