Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » Problems in LibItsBtp_EncdecDeclarations.hh
Problems in LibItsBtp_EncdecDeclarations.hh [message #1792912] Wed, 25 July 2018 15:50 Go to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi Everyone,
I am new here in Eclipse Forum, I am working with Eclipse Titan, and I am trying to work out a project from ETSI, in BTP layer.

I have added to my project all the necessary file and then, eclipse show me a error message in a file that is itself generated, so even I found out the solution it will appear again because every time I compile it eclipse generate it again.

Can someone help to figure it out?

I will attached the error code eclipse show me in console that the file.

LibItsBtp_EncdecDeclarations.hh:40:43: error: 'LibItsBtp__TypesAndValues' does not name a type
extern BITSTRING fx__enc__BtpPacket(const LibItsBtp__TypesAndValues::BtpPacket& p);
^~~~~~~~~~~~~~~~~~~~~~~~~
LibItsBtp_EncdecDeclarations.hh:40:79: error: expected unqualified-id before '&' token
extern BITSTRING fx__enc__BtpPacket(const LibItsBtp__TypesAndValues::BtpPacket& p);
^
LibItsBtp_EncdecDeclarations.hh:40:79: error: expected ')' before '&' token
LibItsBtp_EncdecDeclarations.hh:40:81: error: expected initializer before 'p'
extern BITSTRING fx__enc__BtpPacket(const LibItsBtp__TypesAndValues::BtpPacket& p);
^
LibItsBtp_EncdecDeclarations.hh:41:49: error: 'LibItsBtp__TypesAndValues' has not been declared
extern INTEGER fx__dec__BtpPacket(BITSTRING& b, LibItsBtp__TypesAndValues::BtpPacket& p);
^~~~~~~~~~~~~~~~~~~~~~~~~
LibItsBtp_EncdecDeclarations.hh:41:85: error: expected ',' or '...' before '&' token
extern INTEGER fx__dec__BtpPacket(BITSTRING& b, LibItsBtp__TypesAndValues::BtpPacket& p);

Thanks in Advance,
Marta
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793002 is a reply to message #1792912] Fri, 27 July 2018 11:46 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris KolovosFriend
Messages: 1613
Registered: July 2009
Location: York, UK
Senior Member

Hi Marta,

The Titan forum [1] seems to be a better fit for this message.

Cheers,
Dimitris

[1] https://www.eclipse.org/forums/index.php?t=thread&frm_id=297
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793094 is a reply to message #1793002] Tue, 31 July 2018 06:34 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 854
Registered: January 2015
Senior Member
Hola Marta,

welcome to Titan.

First, let's clarify where did you get your code from?

If it's from http://oldforge.etsi.org/websvn/listing.php?repname=ITS.ITS&path=%2Fbranches%2FSTF525%2F&#a36901563a51d1f9a55a06daf758a66d1

then I'd defer this to Yann. this is his stuff.


Best regards
Elemer

Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793096 is a reply to message #1793094] Tue, 31 July 2018 06:50 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hello Elmer,

First of all, thanks for your welcome!

About your question, the answer is yes, I got the code from there. So if Yann could help I will be gratefull.

In the other hand, I am also trying a parallel project that I got from: https://github.com/elnrnag/ITSG5_TS_Titanized_TA
I am working just with AtsBTP as in the other project and I have the following problem, hoppping that you could help me.

1) In LibItsBtp_Functions:
Description Resource Path Location Type
Message type `@LibItsBtp_TypesAndValues.UtBtpTrigger' is not present on the outgoing list of port type `@LibItsBtp_TestSystem.UpperTesterPort' LibItsBtp_Functions.ttcn /ITSg5/ttcn/LibIts/BTP line 71 on-the-fly semantic markers.


I attached the file just in case

2)We I try to run it, even with the error, It seems like it is runinng but it does nothing and when I stop it, it shows the following errors in console:

Error: Error message was received from HC at DTM-0218-R.at4wireless.com [192.168.1.100]: Error while setting parameter field 'LibCommon_Time.PX_TWAIT' to '120.000000': Module parameter cannot be set, because module 'LibCommon_Time' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
Error: Error message was received from HC at DTM-0218-R.at4wireless.com [192.168.1.100]: Error while setting parameter field 'LibCommon_Sync.PX_TSYNC_TIME_LIMIT' to '120.000000': Module parameter cannot be set, because module 'LibCommon_Sync' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
Error: Error message was received from HC at DTM-0218-R.at4wireless.com [192.168.1.100]: Error while setting parameter field 'LibItsBtp_Pixits.PX_DESTINATION_PORT' to '4000': Module parameter cannot be set, because module 'LibItsBtp_Pixits' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
Error: Error message was received from HC at DTM-0218-R.at4wireless.com [192.168.1.100]: Error while setting parameter field 'LibItsBtp_Pixits.PX_SOURCE_PORT' to '5000': Module parameter cannot be set, because module 'LibItsBtp_Pixits' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
HC@DTM-0218-R: Error while setting parameter field 'LibCommon_Time.PX_TWAIT' to '120.000000': Module parameter cannot be set, because module 'LibCommon_Time' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
HC@DTM-0218-R: Error while setting parameter field 'LibCommon_Sync.PX_TSYNC_TIME_LIMIT' to '120.000000': Module parameter cannot be set, because module 'LibCommon_Sync' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
HC@DTM-0218-R: Error while setting parameter field 'LibItsBtp_Pixits.PX_DESTINATION_PORT' to '4000': Module parameter cannot be set, because module 'LibItsBtp_Pixits' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
HC@DTM-0218-R: Error while setting parameter field 'LibItsBtp_Pixits.PX_SOURCE_PORT' to '5000': Module parameter cannot be set, because module 'LibItsBtp_Pixits' does not exist. (Note: field names and array indexes are not supported in the Load Test Runtime).
Error: There were errors during configuring HCs.
Error during initialization. Cannot create MTC.


It a quite strange error because those file does exits in the project.
I also attached the all project.

I have not modify any file, I just delete from the project the files that I do not need to run AtsBtp.

If you think is better, I could post this new errors like a new topic

Thanks a lot,
Marta

[Updated on: Tue, 31 July 2018 06:53]

Report message to a moderator

Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793107 is a reply to message #1792912] Tue, 31 July 2018 08:50 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi Marta,

I have checked the zip file You have uploaded, and found that You have deleted some files from the project which are needed for the compilation.

I have just tried to clone, compile and run the repo, and it works on my system.
If You clone the repo and follow the steps in the README.md file does the intact repo build for You correctly?

Regards,
Lenard
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793113 is a reply to message #1793107] Tue, 31 July 2018 10:21 Go to previous messageGo to next message
Yann Garcia is currently offline Yann GarciaFriend
Messages: 63
Registered: June 2016
Member
Hello Marta,

I'm Yann Garcia, consultant at ETSI and I'm working on the ETSI STF 525.

If you need some help, pease don't hesitate to contact me too ;)

Best regards,

Yann Garcia
Senior Software Engineer
Microsoft MCAD.net Certified
**************************************
FSCOM SARL
Le Montespan B2
6, Avenue des Alpes
F-06600 Antibes, FRANCE
************************************************
Tel: +33 (0)4 92 94 49 08
Mobile: +33 (0)7 61 00 77 05
Email: yann.garcia@fscom.fr
Skype: yann.garcia
Google+: garcia.yann@gmail.com
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793115 is a reply to message #1793113] Tue, 31 July 2018 10:36 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi Everyone,

Thanks you a lot for answering so quickly.

About all you answers:

-Yann, how would you like me to contact with you?
Here in a new topic, or via email or whatever would be better for you? Just tell me please.

-Lenard, I have tried several times to run it on my computer following the steps from the file readme but after installing it, when I write comando make it does appear the same error all the time:
#error This file should be compiled on WIN32
And because it shows this error it is not possible for me to continue and run it.
I have installed the 32bit version of the compilator on my computer thinking that it was going to be the solution of my problem but the same error appear again, so that's the reason why I decided to try in directly on eclipse deleting the files I thought that were not needed.

Tell me if you know another way to solve it.

Thanks a lot again everyone,
Marta
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793120 is a reply to message #1793115] Tue, 31 July 2018 11:11 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi Marta,

What is the operating system of your computer?

Lenard
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793123 is a reply to message #1793120] Tue, 31 July 2018 11:21 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi Lenard,

It is windows 10.

Marta
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793124 is a reply to message #1793123] Tue, 31 July 2018 11:37 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi,

This stack I have created and used under linux, and have never tried to compile or run it on windows/cygwin.

I recommend to use linux to try it out, for which 2 ways are feasible:

1: Install a standalone linux system (I recommend Ubuntu, but any other distro may be used) either on a virtual machine or on a separate physical computer. After installing and configuring Titan on this system compiling the stack should not be a problem

2: You might want to use the linux subsytem in windows10 (not cygwin), it should also work, but I have never used it.

Lenard
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793126 is a reply to message #1793124] Tue, 31 July 2018 11:50 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 854
Registered: January 2015
Senior Member
Hi Marta,

Titan is primarily intended for Unix/Linux ;
anything else ( meaning Linux emulators/simulators on Windows) calls for compromises , so we recommend some kind of a Linux distribution to be used with Titan.


Best regards
Elemer



Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793150 is a reply to message #1793126] Tue, 31 July 2018 16:11 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi Everyone,

I have tried it on Ubuntu and it seems to work, I will try it on my device and I will tell you again.

I am really grateful, Thanks a lot both!

Best Regards,
Marta
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793180 is a reply to message #1793150] Wed, 01 August 2018 07:00 Go to previous messageGo to next message
Yann Garcia is currently offline Yann GarciaFriend
Messages: 63
Registered: June 2016
Member
Hello Marta,

May I ask you which device are you using? Did you develop it?
If you are interested, we can do some remote tests, I manage the Test System side (which still is in development) and you can be focused on your own development.

Have a nice day,

BR\ Yann
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793289 is a reply to message #1793180] Fri, 03 August 2018 06:47 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hello all,

I am trying it on a Cohda Wireless and I have another doubt.

I have been trying the project and it does work, but not at all, I think I know where is the problem but I do not know how to solve it.

When I execute it, for example BTP procotol, it starts and works correctly but it does not pass any test, the verdict is almost the times inconclusive and I would say that it is because I am not setting all the configuration files as they should be.

I have just changed; "upper tester settings", "local mac ethernet" and "gn6 address" in taproperties.cfg that is in titan_tri_mapper folder.

Do I need to change something else? Because I think that it does not work at all because the btp port ( in this example) is not working, I mean it is not properly set up; because it is initialized via UtPort and the time run out waiting for a packet from btpPort.

Am I right? Hope someone of you could help me.

Thanks in advance,
Best Regards.
Marta.
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793295 is a reply to message #1793289] Fri, 03 August 2018 10:59 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi Marta,

Some of these instructions may seem dumb, but nevertheless I'd like to avoid all possible problems:

-- Set the correct IP and port:
- In taproperties.cfg You need to set the following values:
"UpperTesterSettings": "<IP_OF_COHDA>:<PORT>",
- This must match the port setting on the COHDA:
UpperTesterUdpRxPort = <PORT>
in the config file ets-btp.conf

-- Set the correct MAC address in taproperties.cfg
"LocalEthernetMAC": "<MAC>"
- Where <MAC> is the MAC address of the interface you use to reach the COHDA

-- Set the correct MAC address in LibItsGeoNetworking_Pics.ttcn:
PICS_GN_LOCAL_GN_ADDR.mid := <MAC_TO_IUT> // Same as LocalEthernetMAC
PICS_IUT_MAC_ADDRESS := <MAC_TO_IUT> // Same as LocalEthernetMAC

-- On the COHDA start the UpperTester software:
root@MK5:~# cd ./c2xapp/c2x-app/
root@MK5:~/c2xapp/c2x-app# ./c2x-app_mk5_release -d ets-btp.conf -c fixes.conf

-- Start the TitanTRIMapper on Your computer:
> cd ./ITSG5_TS_Titanized_TA/titan_tri_mapper/
> java -jar ./TitanTriMapper.jar -l info

-You should see the following printout:
[INFO] Waiting for connections...
[INFO] Opening socket on port 2222

After setting all this the BTP tests should pass.

If they do not pass, please send me:
- taproperties.cfg
- <PROJECT_ROOT>/ttcn/LibIts/GeoNetworking/LibItsGeoNetworking_Pics.ttcn
- the console printouts of TitanTriMapper
- the titan logs of the test execution
- the printout in a linux console of your machine's IP interface settings (You can obtain it by running "ifconfig -a" in a linux shell)
- the contents of the COHDA log folder. This folder is auto-generated every time You start the UpperTester, and is printed out, e.g.:
"Log directory is /tmp/1970.0221.2214_C04E548019DA0-0000_14825"
- the ets_btp.conf and the fixes.conf files from the COHDA's /c2xapp/c2x-app/ directory
- the console logs of the COHDA

Regards,
Lenard














Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793296 is a reply to message #1793295] Fri, 03 August 2018 11:51 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi Marta,

And I forgot one more thing: If there is any firewall between Titan and the COHDA please make sure the ports used for communication are not blocked. TitanTRIMapper uses 2222 TCP port, the UpperTester uses the 12345 UDP port, which is dependent on your configuration.

Lenard
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793386 is a reply to message #1793296] Tue, 07 August 2018 08:52 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi Lenard,

I have tried with all the details you told me, and unfornatelly I obtained the same results, for BTP test cases, 3 inconcs and 2 errors. I have also tried to disable the firewall of my computer and the results were again the same.

The reasons of the inconcs verdicts is: INCONC: Expected BTP packet not received

I am going to attach, all the things you have asked for.

PS: I have 3 times the file taproperties.cfg, in different folders, I modified one and copy and paste for the other ones, I am not sure if they have to be all equal.

--taproperties.cfg
{
"LinkLayer_NodeA": "BABEBABE0001",
"TsBeaconInterval": "1000",
"LinkLayer_NodeF": "BABEBABE0006",
"Gn6RemoteAdapterIp": "192.168.1.102",
"UtSecuredMode": "false",
"LinkLayer_NodeB": "BABEBABE0002",
"LinkLayer_NodeC": "BABEBABE0003",
"LinkLayer_NodeD": "BABEBABE0004",
"LinkLayer_NodeE": "BABEBABE0005",
"mapSpatPort": "BTP/GN/ETH",
"TsSecuredRootPath": "data/certificates",
"UpperTesterSettings": "192.168.1.102:12345",
"IutEthernetTypeValue": "0x8947",
"LocalEthernetMAC": "000c298f6c0f",
"ipv6OverGeoNetworkingPort": "Debug",
"btpPort": "GN/ETH",
"TsSecuredMode": "false",
"TsSecuredConfiId": "vendorA",
"LinkLayer_MTC": "BABEBABE0000",
"TsLatitude": "7000",
"geoNetworkingPort": "ETH",
"TsLongitude": "520000",
"camPort": "BTP/GN/ETH",
"denmPort": "BTP/GN/ETH"
}


--"ifconfig -a"
ifconfig -a
ens33 Link encap:Ethernet HWaddr 00:0c:29:8f:6c:0f
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::c39c:ecd0:a119:4b94/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9646 errors:0 dropped:5754 overruns:0 frame:0
TX packets:716 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:778880 (778.8 KB) TX bytes:87852 (87.8 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:44071 errors:0 dropped:0 overruns:0 frame:0
TX packets:44071 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3516794 (3.5 MB) TX bytes:3516794 (3.5 MB)


-- the console logs of the COHDA
root@MK5:/mnt/ubi/c2x-app# ./c2x-app_mk5_release -d ets-btp.conf -c fixes.conf
main FNSTART: App Init...
App Init...
libPlat_Init FNSTART: (0x7e9f2564)
Conf: ets-btp.conf opened
Conf: fixes.conf opened
ConfigGet: ConfigGet() 0x129a1c8 -> 3
ConfigGet: ConfigGet() 0x129a1c8 -> 4
ConfigGet: ConfigGet() 0x129a1c8 -> 5
Log_GetBaseDir: stat(/mnt/ubi/log): 0
_ConfigRelease: _ConfigRelease() 0x129a1c8 -> 4 (refcount not zero)
Log_Init: Logging directory /mnt/ubi/log exists
ConfigGet: ConfigGet() 0x129a1c8 -> 5
ConfigGet: ConfigGet() 0x129a1c8 -> 6
Log_GetBaseDir: stat(/mnt/ubi/log): 0
_ConfigRelease: _ConfigRelease() 0x129a1c8 -> 5 (refcount not zero)
ConfigGet: ConfigGet() 0x129a1c8 -> 6
_ConfigRelease: _ConfigRelease() 0x129a1c8 -> 5 (refcount not zero)
_ConfigRelease: _ConfigRelease() 0x129a1c8 -> 4 (refcount not zero)
Log_Init: mkdir(/mnt/ubi/log/2018.0807.0806_C04E548019298-0000_1509/): OK
Log_Init: replaced symlink(2018.0807.0806_C04E548019298-0000_1509, /mnt/ubi/log/ current): 0
Log directory is /mnt/ubi/log/2018.0807.0806_C04E548019298-0000_1509
Log_RedirectFd FNSTART: (1, 0, /mnt/ubi/log/2018.0807.0806_C04E548019298-0000_15 09, stdout)
Log_RedirectFd FNEND: (1, 0, /mnt/ubi/log/2018.0807.0806_C04E548019298-0000_1509 , stdout): disabled
Log_RedirectFd FNSTART: (2, 1, /mnt/ubi/log/2018.0807.0806_C04E548019298-0000_15 09, stderr)
Log_RedirectFd: open(/mnt/ubi/log/2018.0807.0806_C04E548019298-0000_1509/stderr) : 3
libPlat Init...
libITSNet Init...
libITSFL Init...
RUNNING...


Thanks again!
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793645 is a reply to message #1793386] Mon, 13 August 2018 07:39 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi Marta,

With which command are You starting the TRI mapper?
It needs superuser (root) rights to run properly, under Ubuntu You may use the command "sudo java -jar ./TitanTriMapper.jar -l info", or use the "sudo su -" command and then use "java -jar ./TitanTriMapper.jar -l info" in the root prompt

Lenard
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793969 is a reply to message #1793645] Tue, 21 August 2018 10:59 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi again Lenard,

I had always use the command "sudo java -jar ./TitanTriMapper.jar -l info", but this time I have tried with the other one you have recommend me and unfortunatelly I obtained the same result.
I have been reading carefully the comand window where Tri Mapper is running and I have found the following problems:

-java.lang.UnsatisfiedLinkError: no jnetpcap in java.library.path

-java.lang.NoClassDefFoundError: Could not initialize class org.etsi.its.adapter.PcapMultiplexer


I am going to try to solve it and I will come back again to tell you about my results.

If you know something about them that could help me to solve it please tell me.

BR,
Marta
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793991 is a reply to message #1793969] Wed, 22 August 2018 04:27 Go to previous messageGo to next message
Lenard Nagy is currently offline Lenard NagyFriend
Messages: 26
Registered: September 2016
Junior Member
Hi Marta,

You'll need libpcap installed on the machine.

On my system there are 2 versions of the library:
/usr/lib/x86_64-linux-gnu/libpcap.so.1.7.4
/usr/lib/x86_64-linux-gnu/libpcap.so.0.8

You'll need to add the directory containing these files to LD_LIBRARY_PATH.

If that does not help try to make symbolic links to one of these files with the name "libpcap.so"

Lenard
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1793996 is a reply to message #1793991] Wed, 22 August 2018 06:27 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 854
Registered: January 2015
Senior Member
Hi Marta,


of course , libpcap will be supportingteh C++ part;

for the Java part, you will need jnetpcap as you noticed.

Best regards
Elemer




Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1794144 is a reply to message #1793996] Fri, 24 August 2018 10:06 Go to previous messageGo to next message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi everyone,

I have tried with everthing you have told me.
I have added the directory where the libpcap's file are and also the one where jnetpcap.jar is, both to LD_LIBRARY_PATH. In addition I have installed jnetpcap directly to eclipse but I have not found the solution yet.

I will continue looking for another solution and I will come again.

Thanks a lot for you help,
BR
Marta
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1794145 is a reply to message #1794144] Fri, 24 August 2018 10:28 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 854
Registered: January 2015
Senior Member
Hi Maria,


take a wireshark trace and upload it;

maybe we can see where is the mismatch.


BR

Elemer
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1794147 is a reply to message #1794145] Fri, 24 August 2018 10:46 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 854
Registered: January 2015
Senior Member
Hi Maria, me again,

in order for Wireshark to be able to dissect ITS packages you need to install plug-ins which can be downloaded from:

http://oldforge.etsi.org/websvn/listing.php?repname=ITS.WIRESHARK_ITS_PLUGINS


You also need the latest version of Wireshark for that.

BR

Elemer

Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1794148 is a reply to message #1794147] Fri, 24 August 2018 11:32 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 854
Registered: January 2015
Senior Member
Also,

please upload the TTCN and Java log files in sync with the Wireshark trace.

BR

Elemer
Re: Problems in LibItsBtp_EncdecDeclarations.hh [message #1794627 is a reply to message #1794148] Tue, 04 September 2018 07:31 Go to previous message
Marta Arrabal is currently offline Marta ArrabalFriend
Messages: 10
Registered: July 2018
Junior Member
Hi Elemer,

Thanks for you attention and sorry for not answerring before, it was not possible for me.
I will prepare everything you have asked for and I will come back with all that files.

Thanks again!
BR,
Marta
Previous Topic:compiler: Support of ABSENT and PRESENT PresenceConstraints
Next Topic:Compiling socketcan test port fails when using eclipse-titan packages on debian and ubuntu
Goto Forum:
  


Current Time: Sun Nov 18 09:44:18 GMT 2018

Powered by FUDForum. Page generated in 0.03121 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top