Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installing Papyrus Moka in Eclipse Photon(Is it possible to install Papyrus Moka in last Eclipse Photon version?)
Installing Papyrus Moka in Eclipse Photon [message #1792873] Wed, 25 July 2018 10:06
Jesús Gorroñogoitia is currently offline Jesús GorroñogoitiaFriend
Messages: 1
Registered: July 2018
Junior Member
Is it possible to install Papyrus Moka in last Eclipse Photon version?
In Eclipse Oxygen it is. Papyrus Moka was shipped within Eclipse Oxygen Modeling, but not in Eclipse Photon.
Indeed, in Eclipse Photon modeling there is no longer available the option in Help menu to install modeling components or additional Papyrus components. If you go to Help/Install new software and select the Photon update site and the modeling category, you can install Papyrus (there is only a single feature to install, not individual packages), but not Moka.

Therefore, I tried to install Moka (after installing Papyrus as commented above) using the Moka update site:
http://download.eclipse.org/modeling/mdt/papyrus/components/moka

but the dependency manager didn't succeed to find out the require dependencies:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Moka For Cosimulation (Incubation) 3.0.0.201710171318 (org.eclipse.papyrus.moka.fmi.feature.feature.group 3.0.0.201710171318)
  Missing requirement: org.eclipse.papyrus.moka.datavisualization.ui 1.0.100.201705162304 requires 'osgi.bundle; org.eclipse.papyrus.infra.properties [2.0.0,3.0.0)' but it could not be found
  Missing requirement: SIMplified EXecutable UML 2.0.100.201709250712 (org.eclipse.papyrus.moka.simex 2.0.100.201709250712) requires 'osgi.bundle; org.eclipse.papyrus.infra.viewpoints.policy [2.0.0,3.0.0)' but it could not be found
  Missing requirement: SIMplified EXecutable UML 2.0.100.201710171318 (org.eclipse.papyrus.moka.simex 2.0.100.201710171318) requires 'osgi.bundle; org.eclipse.papyrus.infra.viewpoints.policy [2.0.0,3.0.0)' but it could not be found
  Missing requirement: org.eclipse.papyrus.moka.xygraph.modelexplorer 1.0.0.201705162310 requires 'osgi.bundle; org.eclipse.papyrus.infra.viewpoints.policy [1.2.0,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Moka Core (Incubation) 2.0.0.201705162310 (org.eclipse.papyrus.moka.feature.feature.group 2.0.0.201705162310)
    To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.moka.xygraph.modelexplorer [1.0.0.201705162310,1.0.0.201705162310]
  Cannot satisfy dependency:
    From: Moka Core (Incubation) 2.0.100.201705162304 (org.eclipse.papyrus.moka.feature.feature.group 2.0.100.201705162304)
    To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.moka.datavisualization.ui [1.0.100.201705162304,1.0.100.201705162304]
  Cannot satisfy dependency:
    From: Moka Core (Incubation) 3.0.0.201709250712 (org.eclipse.papyrus.moka.feature.feature.group 3.0.0.201709250712)
    To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.moka.simex [2.0.100.201709250712,2.0.100.201709250712]
  Cannot satisfy dependency:
    From: Moka Core (Incubation) 3.1.0.201710171318 (org.eclipse.papyrus.moka.feature.feature.group 3.1.0.201710171318)
    To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.moka.simex [2.0.100.201710171318,2.0.100.201710171318]
  Cannot satisfy dependency:
    From: Moka For Cosimulation (Incubation) 3.0.0.201710171318 (org.eclipse.papyrus.moka.fmi.feature.feature.group 3.0.0.201710171318)
    To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.moka.feature.feature.group 0.0.0


despite I added the Orbit repository suggested in another forum discussion thread:
http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository/


Has been Moka upgraded to Photon? Could it be installed in Photon?

Thank you very much for you help.
Yosu
Previous Topic:Disabling "Active Gradient" in Papyrus
Next Topic:"Unresolved resource" error occurring during Collaborative work
Goto Forum:
  


Current Time: Sun Sep 23 11:15:12 GMT 2018

Powered by FUDForum. Page generated in 0.01551 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top