Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Why does Neon1 start empty tomcat9 900ms while Oxygen and Photon start it need 20000ms?(Same laptop and only the difference is Eclipse version.)
Why does Neon1 start empty tomcat9 900ms while Oxygen and Photon start it need 20000ms? [message #1792691] Sun, 22 July 2018 03:31 Go to next message
qingy zhang is currently offline qingy zhangFriend
Messages: 3
Registered: July 2018
Junior Member


Same laptop and only the difference is Eclipse version.

win10 - i5 7300HQ - 8G

I found the starting process in console mainly stop seconds after showing message in these 5 places.

1.Deploying web application directory [D:\mine\doc\apache-tomcat-9.0.10\webapps\docs]

2.Deploying web application directory [D:\mine\doc\apache-tomcat-9.0.10\webapps\examples]

3.Deploying web application directory [D:\mine\doc\apache-tomcat-9.0.10\webapps\host-manager]

4.Deploying web application directory [D:\mine\doc\apache-tomcat-9.0.10\webapps\manager]

5.Deploying web application directory [D:\mine\doc\apache-tomcat-9.0.10\webapps\ROOT]

Version: Photon Release (4.8.0) Server startup in 22290 ms

BUT Neon1's Tomcat starting process won't stop 1 second at those 5 places.

Version: Neon.1 Release (4.6.1) Server startup in 932 ms

I want to use latest verson of Eclipse but I cant find a solution to this issue.Could someone help me with it?Thanks a Lot.

[Updated on: Sun, 22 July 2018 05:37]

Report message to a moderator

Re: Why does Neon1 start empty tomcat9 900ms while Oxygen and Photon start it need 20000ms? [message #1792694 is a reply to message #1792691] Sun, 22 July 2018 08:39 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29482
Registered: July 2009
Senior Member
It might be best to ask on the Web Tools forum

https://www.eclipse.org/forums/eclipse.webtools

Or to open a problem report using

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=WTP%20ServerTools

Of course in the case of a problem report, an actual test case that reproduces the problem would be a good thing.
Re: Why does Neon1 start empty tomcat9 900ms while Oxygen and Photon start it need 20000ms? [message #1792695 is a reply to message #1792694] Sun, 22 July 2018 09:50 Go to previous message
qingy zhang is currently offline qingy zhangFriend
Messages: 3
Registered: July 2018
Junior Member
Thanks.Already report a bug.
Previous Topic:Latest Version of Eclipser StartTomcat Delay
Next Topic:"dirty files "?
Goto Forum:
  


Current Time: Sat Aug 18 02:34:54 GMT 2018

Powered by FUDForum. Page generated in 0.03038 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top