Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse not running Activator from latest installed plugin.
Eclipse not running Activator from latest installed plugin. [message #1791707] Wed, 04 July 2018 12:29 Go to next message
Archana Singh is currently offline Archana SinghFriend
Messages: 3
Registered: July 2018
Junior Member
Eclipse is not picking the highest version plugin when different versions of a same bundle exists. Bundles are marked as singleton and I have also changed its symbolic name still eclipse is not running the changes made in the latest version. If I uninstall the older version then it is working fine.

What changes should I make so that the highest version plugin is picked?
Re: Eclipse not running Activator from latest installed plugin. [message #1791761 is a reply to message #1791707] Thu, 05 July 2018 05:03 Go to previous message
Archana Singh is currently offline Archana SinghFriend
Messages: 3
Registered: July 2018
Junior Member
Archana Singh wrote on Wed, 04 July 2018 12:29
Eclipse is not picking the highest version plugin when different versions of a same bundle exists. Bundles are marked as singleton and I have also changed its symbolic name still eclipse is not running the changes made in the latest version. If I uninstall the older version then it is working fine.

What changes should I make so that the highest version plugin is picked?

FYI I am installing plugin which will show a new subsystem inside RSE view. Suppose I have installed version 1.0.0 and 2.0.0(with some changes in adapter class) but it is still showing node according to version 1.0.0.

Changes made to plugin.xml of version 2.0.0 are picked up correctly.
Previous Topic:NoClassDefFoundError when calling Class.forName
Next Topic:Jeasyopc and rcp (Property file javafish.clients.opc.JCustomOpc doesn't exist. System terminated.)
Goto Forum:
  


Current Time: Fri Jul 20 16:28:28 GMT 2018

Powered by FUDForum. Page generated in 0.02613 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top