Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Pb change version ECP(org.eclipse.emf.ecp.ui.view.ECPRendererException: No EMFFormsRendererService available! at org.eclipse.emf.ecp.view.internal.swt.ECPSWTViewRendererImpl.render(ECPSWTViewRendererImpl.java:95))
Pb change version ECP [message #1791647] Tue, 03 July 2018 10:04 Go to next message
antonio guillen is currently offline antonio guillenFriend
Messages: 34
Registered: January 2014
Member
Hi all,

I have updated ECP with version 1.17 and now I have the following problem:

org.eclipse.emf.ecp.ui.view.ECPRendererException: No EMFFormsRendererService available!
at org.eclipse.emf.ecp.view.internal.swt.ECPSWTViewRendererImpl.render(ECPSWTViewRendererImpl.java:95).

My code is this one:
    if (selectedNode != null && !(selectedNode instanceof Group)) {
      try {
        if ((scrolledComponent != null) && (!scrolledComponent.isDisposed())) {
          scrolledComponent.dispose();
        }
        scrolledComponent =
            new ScrolledComposite(myParent, SWT.H_SCROLL | SWT.V_SCROLL | SWT.BORDER);
        content = new Composite(scrolledComponent, SWT.NONE);
        content.setBackground(myParent.getDisplay().getSystemColor(SWT.COLOR_WHITE));
        content.setLayout(GridLayoutFactory.fillDefaults().margins(10, 10).create());
        content.setLayoutData(GridDataFactory.fillDefaults().create());
        if (ProjectImpl.getCurrentProject() != null) {
          for (Control kid : content.getChildren()) {
            kid.dispose();
          }
          try {
            VView view = ViewProviderHelper.getView(selectedNode, null);
            DefaultReferenceService service = new DefaultReferenceService();
            final ViewModelContext vmc = ViewModelContextFactory.INSTANCE
                .createViewModelContext(view, selectedNode, service);
            ECPSWTViewRenderer.INSTANCE.render(content, vmc);
            content.layout();
          } catch (final /* ECPRenderer */Exception e) {
             e.printStackTrace();
          }
          content.getParent().layout();
          content.setSize(content.computeSize(SWT.DEFAULT, SWT.DEFAULT));
          scrolledComponent.setContent(content);
          scrolledComponent.getParent().layout();
        }
      } catch (Exception e) {
        e.printStackTrace();
      }
    }
  


Can you help me?
Re: Pb change version ECP [message #1791694 is a reply to message #1791647] Wed, 04 July 2018 09:18 Go to previous messageGo to next message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 147
Registered: May 2015
Senior Member
Hi Antonio,

from which version are you upgrading?
Do you have errors when validating your run config?

Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Pb change version ECP [message #1791699 is a reply to message #1791694] Wed, 04 July 2018 10:30 Go to previous messageGo to next message
antonio guillen is currently offline antonio guillenFriend
Messages: 34
Registered: January 2014
Member
Hi was before on version 1.16 and in the run configuration I validate the plugins and all is OK

Here you will found all the pugins I use
Re: Pb change version ECP [message #1791700 is a reply to message #1791699] Wed, 04 July 2018 10:54 Go to previous messageGo to next message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 147
Registered: May 2015
Senior Member
Hi,

hmm.
You could try to add the "org.eclipse.emfforms.setup.base" and check which bundles are missing using the "Validate Plug-ins" button.
You can ignore *.indexdmr and *.mappingdmr bundles if you have them in your run config.

I hope this helps.
Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Pb change version ECP [message #1791705 is a reply to message #1791700] Wed, 04 July 2018 12:27 Go to previous messageGo to next message
antonio guillen is currently offline antonio guillenFriend
Messages: 34
Registered: January 2014
Member
If i add this plugin ("org.eclipse.emfforms.setup.base") I am oblige to add (see attachement) but also I cannot anymore ignore *.indexdmr and *.mappingdmr bundles.


This doesn't solve the problem still the same error!!!

Re: Pb change version ECP [message #1791718 is a reply to message #1791705] Wed, 04 July 2018 13:04 Go to previous messageGo to next message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 147
Registered: May 2015
Senior Member
Hi,

Are you using Photon by any chance?

Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Pb change version ECP [message #1791722 is a reply to message #1791718] Wed, 04 July 2018 13:20 Go to previous messageGo to next message
antonio guillen is currently offline antonio guillenFriend
Messages: 34
Registered: January 2014
Member
Hi Eugen,

Yes I use Photon is for this reason that I use 1.17, is this the reason? If yes, I understand.

Cheers

Antonio
Re: Pb change version ECP [message #1791730 is a reply to message #1791722] Wed, 04 July 2018 14:04 Go to previous messageGo to next message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 147
Registered: May 2015
Senior Member
Hi,

Photon is the reason. We debugged the same error as you have today.
Photon changed the order in which bundles are started.
Equinox.ds is setting a property which tells Apache Felix SCR to keep services even if they are no longer used by anybody. Before Photon Equinox ds was started with "start level" 1 and "auto start" true. With Photon this is no longer the case and Apache Felix SCR is started instead.
With this config the parameter Equinox.ds was setting is no longer available and the service is disposed. This uncovers a bug in ecp.
So we know of 2 solutions:
1. fix the start order by setting apache.felix.scr auto-start to false and start level to 1
2. manually pass in a system property: "ds.delayed.keepInstances" with the value "true"

Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Pb change version ECP [message #1791740 is a reply to message #1791730] Wed, 04 July 2018 15:25 Go to previous messageGo to next message
antonio guillen is currently offline antonio guillenFriend
Messages: 34
Registered: January 2014
Member
HI Eugen


Thanks a lot for your help. When do you expect fix "this bug", to remove the workaround?

Cheers

Antonio
Re: Pb change version ECP [message #1791758 is a reply to message #1791740] Wed, 04 July 2018 21:53 Go to previous messageGo to next message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 147
Registered: May 2015
Senior Member
Hi Antonio,

I think we will only manage to do it with the 1.18 release which will be part of Photon.1 in September.

Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Pb change version ECP [message #1791759 is a reply to message #1791758] Wed, 04 July 2018 21:53 Go to previous message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 147
Registered: May 2015
Senior Member
Btw here is the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=536692

--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Previous Topic:[EMFForms] Get label + control from view model elements as SWT control?
Next Topic:EMF Forms custom file extension/file type
Goto Forum:
  


Current Time: Tue Sep 25 12:45:57 GMT 2018

Powered by FUDForum. Page generated in 0.03601 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top