Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » install php server on eclipse oxygen(problems to install the php server on eclipse oxygen)
install php server on eclipse oxygen [message #1791113] Sat, 23 June 2018 16:03 Go to next message
Ricardo da Silva Pereira is currently offline Ricardo da Silva PereiraFriend
Messages: 3
Registered: June 2018
Junior Member
Hi everybody
I 'm trying for long time to install the php server on eclipse oxygen, I'm following up many tutorials, many articles about it but nothing worked due must of articles and tutorials are not updated and many instructions are broke and very old version.

First I tried to create a new PHP server
*run on server/ next/installed PHPs/add/browse
and then choose php.ini


After that it asked for : - Enter a label for the PHP executable.
and I get error with anything that I put on field Name.



I had saw an other tutorial about pdt sdk to be installed maybe it should solve my problem.

But when I try to install the pdt and sdk this is what happend:
- Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) JUnit Tests 5.3.0.201803070838 (org.eclipse.php.test.feature.group 5.3.0.201803070838)
Missing requirement: Composer Test plugin 5.3.0.201803070838 (org.eclipse.php.composer.tests 5.3.0.201803070838) requires 'bundle org.eclipse.dltk.core.tests 0.0.0' but it could not be found
Cannot satisfy dependency:
From: PHP Development Tools (PDT) JUnit Tests 5.3.0.201803070838 (org.eclipse.php.test.feature.group 5.3.0.201803070838)
To: org.eclipse.php.composer.tests [5.3.0.201803070838]

Please if someone know how to install the php server correctly please let me know

Thank you!



Re: install php server on eclipse oxygen [message #1791463 is a reply to message #1791113] Fri, 29 June 2018 20:12 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
PDT SDK it's only really usefull if you plan work on PDT Java code. It also require DLTK SDK (you will need additional P2 repository).

What problem you have with PHP server and why you need it?

In general PHP Server feature is used for path mapping between already installed webserver and localfile system during debugging. Especially If you debug remote server.

PDT can also manage built-in php server (start, stop, sync files) but in current state it's not always usable (for example with composer projects).




Re: install php server on eclipse oxygen [message #1791464 is a reply to message #1791113] Fri, 29 June 2018 20:15 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
BTW we already released PDT 6.0 with Eclipse Photon ;)

Re: install php server on eclipse oxygen [message #1791484 is a reply to message #1791463] Sat, 30 June 2018 10:57 Go to previous messageGo to next message
Ricardo da Silva Pereira is currently offline Ricardo da Silva PereiraFriend
Messages: 3
Registered: June 2018
Junior Member
Hi Dawid,
Before of all, thank you so much for your support, but I'm still with problems to mapping or install my PHP server on my eclipse oxygen.

I need to work with PHP using eclipse oxygen,
I have been working with eclipse for long time using Java platform, but now I need to use with PHP platform.



I'm trying to mapping the server like that:
open my project/run on server on my code .php/select PHP built -in Server/next/installed PHPs.../add/bowser/
go to c:/PHP7/php application

and then there is a message above of screen:
Enter a label for the PHP executable.
I tried many different label name it's not working.
(What is it means?)

that's steps that I'm using for an other way :
help/install new software/all site available/ type the filter text "PHP"/select PHP development tools and select PHP development tools SDK/


after that it show me a message on the top:
The installation cannot be completed as requested.
That's details of this error:

Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) JUnit Tests 5.3.0.201803070838 (org.eclipse.php.test.feature.group 5.3.0.201803070838)
Missing requirement: Composer Test plugin 5.3.0.201803070838 (org.eclipse.php.composer.tests 5.3.0.201803070838) requires 'bundle org.eclipse.dltk.core.tests 0.0.0' but it could not be found
Re: install php server on eclipse oxygen [message #1791981 is a reply to message #1791484] Mon, 09 July 2018 09:50 Go to previous message
Ricardo da Silva Pereira is currently offline Ricardo da Silva PereiraFriend
Messages: 3
Registered: June 2018
Junior Member
I found others tutorials talking about the same problem but everyone are saying the same things that I have been tried till now

If someone have any good ideal please let me know
Previous Topic:PDT 6.0 released with Photon!
Next Topic:Eclipse Php : variable undefined evenif it is defined in an require_once php file
Goto Forum:
  


Current Time: Wed Sep 26 02:29:31 GMT 2018

Powered by FUDForum. Page generated in 0.01925 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top