Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » AGPL and RAP EPL 1.0(Can I use Eclipse RAP within an AGPL-ed work?)
AGPL and RAP EPL 1.0 [message #1790304] Fri, 08 June 2018 07:43
Dmitry Ovchinnikov is currently offline Dmitry OvchinnikovFriend
Messages: 1
Registered: June 2018
Junior Member
Hello,

I develop an open-source project with AGPL license. May I include the Eclipse RAP library as a dependency to this project? I read that EPL 1.0 has some incompatibilities with AGPL 3.0 (and GPL 3.0 too), but I'm not a lawyer and there are many details of applying licenses to the own work, therefore I think that the best idea is to get these details from the authors.

If I cannot use Eclipse RAP library in my projects, what options do I have?

(1) To re-license my work to EPL 1.0 or Apache License 2.0 (my project uses only dependencies with Apache License 2.0)
(2) To add some exception statements to the modified AGPL license according to opensource.stackexchange.com/questions/4771/gpl3-project-with-epl-library ?
(3) To ask authors to allow me inclusion of that library licensed under EPL 2.0 (which is, AFAIK, compatible with AGPL) instead of EPL 1.0?

Thank you.
Previous Topic:Background Image on CoolBar
Next Topic:Strange Resize-Event in a Sash
Goto Forum:
  


Current Time: Fri Nov 16 23:12:05 GMT 2018

Powered by FUDForum. Page generated in 0.01323 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top