Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Paho » how do I install paho-mqtt on raspbian stretch python 3.5(install via pip does not work. build from source does not work either.)
how do I install paho-mqtt on raspbian stretch python 3.5 [message #1787464] Fri, 25 May 2018 17:28
Alexander Ryan is currently offline Alexander RyanFriend
Messages: 6
Registered: July 2009
Junior Member
attempted install via pip

(qt) pi@qacker:~ $ which python
/home/pi/berryconda3/envs/qt/bin/python
(qt) pi@qacker:~ $ python --version
Python 3.5.4
(qt) pi@qacker:~ $ pip install paho-mqtt
Traceback (most recent call last):
  File "/home/pi/berryconda3/envs/qt/bin/pip", line 4, in <module>
    import pip
  File "/usr/lib/python3/dist-packages/pip/__init__.py", line 26, in <module>
    from pip.utils import get_installed_distributions, get_prog
  File "/usr/lib/python3/dist-packages/pip/utils/__init__.py", line 30, in <module>
    from pip._vendor.retrying import retry
ImportError: No module named 'pip._vendor.retrying'
(qt) pi@qacker:~ $ 


attempted build

(qt) pi@qacker:~/bitsy_gen3/dev-tools/qacker/paho.mqtt.python $ python setup.py install
running install
Traceback (most recent call last):
  File "setup.py", line 56, in <module>
    setup_requires=setup_requirements
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/dist.py", line 955, in run_commands
    self.run_command(cmd)
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/dist.py", line 974, in run_command
    cmd_obj.run()
  File "/usr/lib/python3/dist-packages/setuptools/command/install.py", line 67, in run
    self.do_egg_install()
  File "/usr/lib/python3/dist-packages/setuptools/command/install.py", line 103, in do_egg_install
    cmd.ensure_finalized()  # finalize before bdist_egg munges install cmd
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/cmd.py", line 107, in ensure_finalized
    self.finalize_options()
  File "/usr/lib/python3/dist-packages/setuptools/command/easy_install.py", line 305, in finalize_options
    'install_lib', ('install_dir', 'install_dir')
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/cmd.py", line 287, in set_undefined_options
    src_cmd_obj.ensure_finalized()
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/cmd.py", line 107, in ensure_finalized
    self.finalize_options()
  File "/usr/lib/python3/dist-packages/setuptools/command/install_lib.py", line 18, in finalize_options
    self.set_undefined_options('install',('install_layout','install_layout'))
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/cmd.py", line 290, in set_undefined_options
    setattr(self, dst_option, getattr(src_cmd_obj, src_option))
  File "/home/pi/berryconda3/envs/qt/lib/python3.5/distutils/cmd.py", line 103, in __getattr__
    raise AttributeError(attr)
AttributeError: install_layout
Previous Topic:Java: QoS 2 wrong packet id
Next Topic:Detect no retained message on subscribe
Goto Forum:
  


Current Time: Fri Nov 16 09:35:00 GMT 2018

Powered by FUDForum. Page generated in 0.02354 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top