Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Photon LLVM configuration problem Debian Buster
Photon LLVM configuration problem Debian Buster [message #1786782] Fri, 11 May 2018 11:01 Go to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 230
Registered: July 2009
Senior Member
I have installed Photon with the LLVM-plugin on Debian Buster. My Debian installation has gcc, llvm/clang and a mingw-64 cross compiler installed.

On the LLVM-preference page I specified:
- LLVM installation folder: /usr/lib/llvm-4.0/bin
- Include directories: /usr/lib/llvm-4.0/include
- Libraries: stdc++
- Library search path directories: /usr/lib/llvm-4.0/lib

But Eclipse automatically adds /usr/lib/gcc/x86_64-w64-mingw32-7.3-win32 to the library search path directories which leads to linker errors. Manually removing this directory does not work: each time Eclipse adds the directory again.

Did I configure Eclipse wrong or is this a bug?

For what it is worth: running "clang++ HelloWorldLLVMClang.cpp" in a terminal results in a perfect working a.out executable.

TIA

Joost

Re: Photon LLVM configuration problem Debian Buster [message #1786785 is a reply to message #1786782] Fri, 11 May 2018 11:14 Go to previous message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 230
Registered: July 2009
Senior Member
An addition to my previous post: the same problem exists in Oxygen.3a Release.

TIA

Joost
Previous Topic:Unable to toggle breakpoint
Next Topic:Problems creating C/C++ Project
Goto Forum:
  


Current Time: Sat Nov 17 07:35:50 GMT 2018

Powered by FUDForum. Page generated in 0.02329 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top