Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installing of eclipse is crashing (WIN10)
Installing of eclipse is crashing (WIN10) [message #1785500] Sun, 15 April 2018 21:35 Go to next message
Andreas Lempik is currently offline Andreas LempikFriend
Messages: 1
Registered: April 2018
Junior Member
Dear community,

i'd really appreciate your help.. Everytime I'm trying to run the eclipse installer there ist this Message seaking me ...

Could anyone help me with this please..?

Quote:
!SESSION 2018-04-15 23:06:38.469 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_161
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64 -data @noDefault

!ENTRY org.eclipse.oomph.setup.installer 4 0 2018-04-15 23:06:43.039
!MESSAGE 0
!STACK 0
java.lang.ArrayIndexOutOfBoundsException: 0
at org.eclipse.oomph.setup.internal.installer.SimpleProductPage.aboutToShow(SimpleProductPage.java:227)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerDialog.doSwitch(SimpleInstallerDialog.java:660)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerDialog.switchToPage(SimpleInstallerDialog.java:672)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerDialog.createUI(SimpleInstallerDialog.java:247)
at org.eclipse.oomph.setup.internal.installer.AbstractSimpleDialog.show(AbstractSimpleDialog.java:139)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.run(InstallerApplication.java:250)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.start(InstallerApplication.java:408)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

!ENTRY org.eclipse.osgi 4 0 2018-04-15 23:06:43.080
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTException: Widget is disposed
at org.eclipse.swt.SWT.error(SWT.java:4533)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.SWT.error(SWT.java:4419)
at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:354)
at org.eclipse.swt.widgets.Shell.getShells(Shell.java:1160)
at org.eclipse.jface.window.Window.getModalChild(Window.java:603)
at org.eclipse.jface.window.Window.lambda$0(Window.java:164)
at org.eclipse.jface.window.Window.getParentShell(Window.java:632)
at org.eclipse.jface.dialogs.IconAndMessageDialog.getSWTImage(IconAndMessageDialog.java:277)
at org.eclipse.jface.dialogs.IconAndMessageDialog.getErrorImage(IconAndMessageDialog.java:236)
at org.eclipse.jface.dialogs.MessageDialog.init(MessageDialog.java:245)
at org.eclipse.jface.dialogs.MessageDialog.<init>(MessageDialog.java:182)
at org.eclipse.oomph.ui.ErrorDialog.<init>(ErrorDialog.java:47)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication$6.<init>(InstallerApplication.java:415)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.start(InstallerApplication.java:415)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
Re: Installing of eclipse is crashing (WIN10) [message #1785531 is a reply to message #1785500] Mon, 16 April 2018 11:12 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29555
Registered: July 2009
Senior Member
Which installer did you download? The code from the stack frames looks kind of old. You can download a newer installer from here:

https://wiki.eclipse.org/Eclipse_Installer

Then if you still have a problem, at least I can at least match the line numbers to my code.
Previous Topic:adt plugin issue
Next Topic:Slow Eclipse
Goto Forum:
  


Current Time: Wed Sep 26 07:17:36 GMT 2018

Powered by FUDForum. Page generated in 0.07923 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top