Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debugger speedups using cython not found(Running Python script in Eclipse: Debugger speedups using cython not found)
Debugger speedups using cython not found [message #1785356] Thu, 12 April 2018 23:14 Go to next message
Jim Lakis is currently offline Jim LakisFriend
Messages: 2
Registered: April 2018
Junior Member
Who I am: Learning client-side developing the last few years, have only used the Eclipse IDE for less than a year...

After ignoring a message in Eclipse stating that "updates are available" for a month, I finally started updating the IDE and the few packages electively installed. This has been the first update cycle I've performed on Eclipse so far.

Once the updating process was finished, simple Python scripts I've previously written were revisited, ie ran. The scripts produce the expected outcomes as before, however a warning message now appears above the output in the console:

warning: Debugger speedups using cython not found. Run '"C: <path omitted> \Programs\Python\Python35\python.exe"
"C: <path omitted> Programs\Active\eclipse\plugins\org.python.pydev.core_6.3.2.201803171248\pysrc\setup_cython.py" build_ext --inplace' to build.

To this novice, it appears to be asking me to run a file in the Python environment.

Is this the case?

How does one do that to be sure that I'd do it correctly?

What is the larger issue here, background?

Thank you very much for any assistance.

--

Eclipse for JavaScript and Web Developers
Version: Oxygen.3a Release (4.7.3a)
Build id: 20180405-1200


Eclipse for JavaScript and Web Developers
Version: Oxygen.3a Release (4.7.3a)
Build id: 20180405-1200
Windows 7 64 bit
Re: Debugger speedups using cython not found [message #1785357 is a reply to message #1785356] Thu, 12 April 2018 23:20 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3155
Registered: July 2009
Senior Member

PyDev is not provided by Eclipse.org. You should start looking for answers to your question at http://www.pydev.org .

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Debugger speedups using cython not found [message #1785359 is a reply to message #1785357] Thu, 12 April 2018 23:29 Go to previous messageGo to next message
Jim Lakis is currently offline Jim LakisFriend
Messages: 2
Registered: April 2018
Junior Member
@Nitin Dahyabhai

Aside from stating that I was tickering with Python scripts in Eclipse, what leads you to make that suggestion?


Eclipse for JavaScript and Web Developers
Version: Oxygen.3a Release (4.7.3a)
Build id: 20180405-1200
Windows 7 64 bit

[Updated on: Thu, 12 April 2018 23:37]

Report message to a moderator

Re: Debugger speedups using cython not found [message #1785360 is a reply to message #1785359] Fri, 13 April 2018 01:29 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3155
Registered: July 2009
Senior Member

The script that the warning message is instructing you to run is within a plug-in
that has pydev as one of its segment names, and would seem to come from
the relevant Github repository, however confusing it is that it starts with
"org.python" when I don't think it's actually related to python.org.


Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Plain text editor templates
Next Topic:Login details for http://www.eclipse.org/setups/setups.zip
Goto Forum:
  


Current Time: Sun May 20 19:49:54 GMT 2018

Powered by FUDForum. Page generated in 0.02781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top