Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Oxygen and High Sierra(Unable to start Oxygen R2 after upgrading to OSX High Sierra)
Oxygen and High Sierra [message #1784666] Sun, 01 April 2018 15:58 Go to next message
Martin Larsson is currently offline Martin LarssonFriend
Messages: 3
Registered: August 2016
Junior Member
I upgraded my OSX from Yosemite to High Sierra. But now Eclipse fails to start. It logs en aerror like "com.apple.xpc.launchd[1] (org.eclipse.platform.ide.7216[39934]): Service exited due to signal: Segmentation fault: 11 sent by exc handler[0]"

Trying to run a newly downloaded installer gives the same problem. A big box with, among other things, an indication of a NULL-pointer:

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

I have no idea where to start looking at this. Any suggestions?
Re: Oxygen and High Sierra [message #1784678 is a reply to message #1784666] Mon, 02 April 2018 08:06 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 403
Registered: August 2014
Senior Member
Your Java may have been replaced together with the upgrade.

Try downloading the current JDK 8 from Oracle Web site <http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html>, setting it up and running the installer again.


--

Tauno Voipio
Re: Oxygen and High Sierra [message #1784682 is a reply to message #1784678] Mon, 02 April 2018 09:56 Go to previous messageGo to next message
Martin Larsson is currently offline Martin LarssonFriend
Messages: 3
Registered: August 2016
Junior Member
Thanks, I'll try that.

Though it seems a bit strange. Running 'java -version' at the command line gives me 'java version "1.8.0_102"'. And running '/usr/libexec/java_home' gives me '/Library/Java/JavaVirtualMachines/jdk1.8.0_102.jdk/Contents/Home'.
On the other hand, I never really understood where Java is located on OS X. And a fresh install of IntelliJ failed to automatically locate any JDK's.
Re: Oxygen and High Sierra [message #1784684 is a reply to message #1784682] Mon, 02 April 2018 10:56 Go to previous messageGo to next message
Martin Larsson is currently offline Martin LarssonFriend
Messages: 3
Registered: August 2016
Junior Member
Installing Java 8 u161 didn't immediately help. But after adding
export JAVA_HOME=$(/usr/libexec/java_home)
to .bash_profile AND restarting, I now have a running Eclipse. Not sure if setting JAVA_HOME or restart did the trick, but at least I can get back to working.

Thanks!
Re: Oxygen and High Sierra [message #1796484 is a reply to message #1784684] Mon, 15 October 2018 07:39 Go to previous message
Jems Ford is currently offline Jems FordFriend
Messages: 2
Registered: September 2018
Junior Member
When you are installing OSX from Yosemite to High Sierra then eclipse is not working in your Apple devices then you can simply reinstall the Eclipse in your Apple devices. If your Apple devices are not working properly, please visit https://www.ipadsupportnumber.com/blog/fix-apple-application-support-error-2/
Previous Topic:Unable to connect Eclipse IDE to Google Source Repository
Next Topic:Eclipse and Hudson build server
Goto Forum:
  


Current Time: Wed Oct 17 01:18:17 GMT 2018

Powered by FUDForum. Page generated in 0.03983 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top