Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Distributed application error(can't get any connection)
Distributed application error [message #1784423] Tue, 27 March 2018 19:18 Go to next message
Rodrigo Esposito is currently offline Rodrigo EspositoFriend
Messages: 24
Registered: August 2016
Junior Member
Hi, its me again. I'm following the distributed application example available at https://www.eclipse.org/4diac/documentation/html/4diacIDE/distribute4diac.html
after the deployment process i got this on my console:
Quote:

WARNING: T#01000ms: Boot file forte.fboot could not be opened
INFO: T#01000ms: CBSDSocketInterface: Opening TCP-Server connection at: localhost:61499
INFO: T#01999ms: FORTE is up and running
INFO: T#013790ms: CBSDSocketInterface: Opening UDP receiving connection at: 239.0.0.1:61000
INFO: T#013790ms: CBSDSocketInterface: Opening UDP receiving connection at: 239.0.0.1:61001
INFO: T#014790ms: Connection closed by peer


Some pictures of my system are attached in this post.
I'm using Ubuntu 16 and 4diac ide 1.8.4 and forte. I also have followed the build guide for the installation.
  • Attachment: fortepc.png
    (Size: 269.39KB, Downloaded 20 times)
  • Attachment: testapp.png
    (Size: 265.66KB, Downloaded 28 times)
  • Attachment: blinktest.png
    (Size: 237.95KB, Downloaded 24 times)
  • Attachment: fbrt_panel.png
    (Size: 272.47KB, Downloaded 28 times)
Re: Distributed application error [message #1784432 is a reply to message #1784423] Tue, 27 March 2018 21:55 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 634
Registered: January 2014
Senior Member
The download went perfeclty fine. The conneciton closed by peer message is just to inform you that the IDE closed the connection with the devices. However you don't see any values as you need to explicitly turn the monitoring on. Please see in the docs for more information on that.
Re: Distributed application error [message #1784512 is a reply to message #1784432] Wed, 28 March 2018 20:37 Go to previous message
Rodrigo Esposito is currently offline Rodrigo EspositoFriend
Messages: 24
Registered: August 2016
Junior Member
Once again, thanks a lot!
Previous Topic:OPC UA Server Client
Next Topic:Did not correctly import old projects (1.8.4) into 1.9.0
Goto Forum:
  


Current Time: Fri Sep 21 15:30:07 GMT 2018

Powered by FUDForum. Page generated in 0.01460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top